aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-10-29 15:25:07 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-12-18 23:28:17 +0900
commit555f641f11a2e19328560d5f3996d7ff032a582f (patch)
tree66c715f6a9f7a7b1c37acb3827031a2affcbe30e /gnu
parent53a457e4a15c1e4a6d3474212bf54b8cede048a2 (diff)
downloadguix-555f641f11a2e19328560d5f3996d7ff032a582f.tar.gz
guix-555f641f11a2e19328560d5f3996d7ff032a582f.zip
gnu: Add ogre-next.
* gnu/packages/graphics.scm (ogre-next): New variable. Change-Id: I0342e7c9917a5bf3c91cf464cf80a9137798b722
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index b4bd05ea8e..cef7ea4c6a 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -127,6 +127,7 @@
#:use-module (gnu packages version-control)
#:use-module (gnu packages video)
#:use-module (gnu packages vulkan)
+ #:use-module (gnu packages web)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
@@ -1255,6 +1256,29 @@ graphics.")
(home-page "https://www.ogre3d.org/")
(license license:expat)))
+(define-public ogre-next
+ (package
+ (inherit ogre)
+ (name "ogre-next")
+ (version "3.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OGRECave/ogre-next")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yrlg3s654xbp95208h9a2b8jcwdk69r6sjvll0aiyvxm4c056cw"))))
+ (arguments (substitute-keyword-arguments (package-arguments ogre)
+ ((#:tests? _ #f)
+ ;; The test suite is currently disabled by the build system
+ ;; (see: https://github.com/OGRECave/ogre-next/issues/466).
+ #f)))
+ (inputs
+ (modify-inputs (package-inputs ogre)
+ (append rapidjson)))))
+
(define-public openexr
(package
(name "openexr")