aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-11 06:55:07 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-12 09:04:06 -0500
commitd2a97aa421e5501f3633bae490e4244680678612 (patch)
treef5c922654c1aeb8a8806874960f4f1948dbf318e /gnu
parent5a9350ae124f23170998ab604dd3f5d90f77af7d (diff)
downloadguix-d2a97aa421e5501f3633bae490e4244680678612.tar.gz
guix-d2a97aa421e5501f3633bae490e4244680678612.zip
gnu: gdk-pixbuf: Add a debug output.
* gnu/packages/gtk.scm (gdk-pixbuf)[outputs]{debug}: New output. [arguments]{modules}: New argument. [phases]{shrink-runpath}: New phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index c58226c5fa..096424e8e3 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -565,12 +565,15 @@ highlighting and other features typical of a source code editor.")
(base32
"1rnlx9yfw970maxi2x6niaxmih5la11q1ilr7gzshz2kk585k0hm"))))
(build-system meson-build-system)
+ (outputs '("out" "debug"))
(arguments
`(#:configure-flags '("-Dinstalled_tests=false")
+ #:modules ((guix build meson-build-system)
+ (guix build utils)
+ (srfi srfi-1))
#:phases
(modify-phases %standard-phases
- (add-after
- 'unpack 'disable-failing-tests
+ (add-after 'unpack 'disable-failing-tests
(lambda _
(substitute* "tests/meson.build"
;; XXX FIXME: This test fails on armhf machines with:
@@ -581,8 +584,13 @@ highlighting and other features typical of a source code editor.")
;; ERROR:pixbuf-jpeg.c:74:test_type9_rotation_exif_tag:
;; assertion failed (error == NULL): Data differ
;; (gdk-pixbuf-error-quark, 0)
- ((".*'pixbuf-jpeg'.*") ""))
- #t))
+ ((".*'pixbuf-jpeg'.*") ""))))
+ (replace 'shrink-runpath
+ ;; Workaround until core-updates is merged (this is fixed in commit
+ ;; ca080b3efb).
+ (lambda* (#:key outputs #:allow-other-keys #:rest args)
+ (apply (assoc-ref %standard-phases 'shrink-runpath)
+ `(,@args #:outputs ,(alist-delete "debug" outputs)))))
;; The slow tests take longer than the specified timeout.
,@(if (any (cute string=? <> (%current-system))
'("armhf-linux" "aarch64-linux"))