aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2024-10-02 19:41:14 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:04:50 +0200
commit45659baef0314a6dee340e3c9a430cd0a3a65c92 (patch)
tree6ef04a28d6d4fad7ed360a6b3cc9d21211328dc2 /gnu
parent66134b9c23015e82219dccc68da363646febf9fe (diff)
downloadguix-45659baef0314a6dee340e3c9a430cd0a3a65c92.tar.gz
guix-45659baef0314a6dee340e3c9a430cd0a3a65c92.zip
gnu: Add rust-windows-interface-0.58.
* gnu/packages/creates-windows.scm (rust-windows-interface-0.58): New variable. (rust-windows-interface-0.52): Inherit from rust-windows-interface-0.58. Change-Id: I4067eeb47867cb65b089e9f3b10c4ac7ce57c69b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-windows.scm29
1 files changed, 23 insertions, 6 deletions
diff --git a/gnu/packages/crates-windows.scm b/gnu/packages/crates-windows.scm
index 415d5d899a..70de1823f8 100644
--- a/gnu/packages/crates-windows.scm
+++ b/gnu/packages/crates-windows.scm
@@ -2086,28 +2086,45 @@ Windows crate.")
(("rust-syn" ,rust-syn-1)
("rust-windows-tokens" ,rust-windows-tokens-0.32))))))
-(define-public rust-windows-interface-0.52
+(define-public rust-windows-interface-0.58
(package
(name "rust-windows-interface")
- (version "0.52.0")
+ (version "0.58.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "windows-interface" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1la254wzd8qlbxplvb667z5mwdh9jngg1qyhxg6fx9wm00pc73cx"))))
+ (base32 "059mxmfvx3x88q74ms0qlxmj2pnidmr5mzn60hakn7f95m34qg05"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
("rust-quote" ,rust-quote-1)
("rust-syn" ,rust-syn-2))))
(home-page "https://github.com/microsoft/windows-rs")
- (synopsis "The interface macro for the windows crate")
- (description "This package provides the interface macro for the windows
-crate.")
+ (synopsis "The interface macro for the Windows crate")
+ (description
+ "This package provides the interface macro for the Windows crate.")
(license (list license:expat license:asl2.0))))
+(define-public rust-windows-interface-0.52
+ (package
+ (inherit rust-windows-interface-0.58)
+ (name "rust-windows-interface")
+ (version "0.52.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "windows-interface" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1la254wzd8qlbxplvb667z5mwdh9jngg1qyhxg6fx9wm00pc73cx"))))
+ (arguments
+ `(#:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-2))))))
+
(define-public rust-windows-interface-0.48
(package
(inherit rust-windows-interface-0.52)