aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2024-10-02 19:28:30 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:04:50 +0200
commit66134b9c23015e82219dccc68da363646febf9fe (patch)
tree8b7da6a71580acabb1138c01089f2a2e5b0dc26d /gnu
parent8f98c0c65a433cbe4ca6903c14c329e8025319cd (diff)
downloadguix-66134b9c23015e82219dccc68da363646febf9fe.tar.gz
guix-66134b9c23015e82219dccc68da363646febf9fe.zip
gnu: Add rust-windows-implement-0.58.
* gnu/packages/crates-windows.scm (rust-windows-implement-0.58): New variable. (rust-windows-implement-0.52): Inherit from rust-windows-implement-0.58. Change-Id: I61c3cb6c0386caa01e9d220d7289b9c1adc9f739
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-windows.scm32
1 files changed, 26 insertions, 6 deletions
diff --git a/gnu/packages/crates-windows.scm b/gnu/packages/crates-windows.scm
index ef9434604f..415d5d899a 100644
--- a/gnu/packages/crates-windows.scm
+++ b/gnu/packages/crates-windows.scm
@@ -1955,8 +1955,33 @@ crate.")
(base32
"0r0z8s1wcdwd20azsdfilf2a6bz68xkavl990wy64hyc8f51bmai"))))))
+(define-public rust-windows-implement-0.58
+ (package
+ (name "rust-windows-implement")
+ (version "0.58.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "windows-implement" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "16spr5z65z21qyv379rv2mb1s5q2i9ibd1p2pkn0dr9qr535pg9b"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-2))))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "The implement macro for the windows crate")
+ (description
+ "This package provides The @code{implement} macro for the
+Windows crate.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-windows-implement-0.52
(package
+ (inherit rust-windows-implement-0.58)
(name "rust-windows-implement")
(version "0.52.0")
(source
@@ -1970,12 +1995,7 @@ crate.")
(arguments
`(#:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
("rust-quote" ,rust-quote-1)
- ("rust-syn" ,rust-syn-2))))
- (home-page "https://github.com/microsoft/windows-rs")
- (synopsis "The implement macro for the windows crate")
- (description "This package provides the @code{implement} macro for the
-windows crate.")
- (license (list license:expat license:asl2.0))))
+ ("rust-syn" ,rust-syn-2))))))
(define-public rust-windows-implement-0.48
(package