aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-12 21:51:30 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:57 +0200
commit43f405a6c5fba468af192193065316e2f044dee9 (patch)
tree950736f19c66ea67c370ee31a6503c66efbe532c /gnu
parentbbbd0229dd8186fb737dc0bd365fdfa057112bb9 (diff)
downloadguix-43f405a6c5fba468af192193065316e2f044dee9.tar.gz
guix-43f405a6c5fba468af192193065316e2f044dee9.zip
gnu: Add texlive-asyfig.
* gnu/packages/tex.scm (texlive-asyfig): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 46756f9706..74b169a619 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16043,6 +16043,31 @@ draws K-maps where the most significant input variables are placed on top of
the columns and the least significant variables are placed left of the rows.")
(license license:lppl)))
+(define-public texlive-asyfig
+ (package
+ (name "texlive-asyfig")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/asyfig/" "source/latex/asyfig/"
+ "tex/latex/asyfig/")
+ (base32
+ "0116a920z8hq3v50gmgh3f8diq7307wx0zsh2pmznw7gkvn6rn4k")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:tex-format "latex"))
+ (native-inputs (list texlive-filecontents))
+ (home-page "https://ctan.org/pkg/asyfig")
+ (synopsis "Commands for using Asymptote figures")
+ (description
+ "The package provides a means of reading Asymptote figures from separate
+files, rather than within the document, as is standard in the @code{asymptote}
+package, which is provided as part of the Asymptote bundle. The Asymptote way
+can prove cumbersome in a large document; the present package allows the user
+to process one picture at a time, in simple test documents, and then to
+migrate (with no fuss) to their use in the target document.")
+ (license license:lppl)))
+
(define-public texlive-auto-pst-pdf-lua
(package
(name "texlive-auto-pst-pdf-lua")