aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-12 21:55:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:01 +0200
commit3d760665ff8b95f12c689960753109736af4b8b6 (patch)
treefbac714e3dee7c817337646a33f1e461ac2a7d5a /gnu
parent36d3ab9e1b126c421ec4f912415198b5a856e4d5 (diff)
downloadguix-3d760665ff8b95f12c689960753109736af4b8b6.tar.gz
guix-3d760665ff8b95f12c689960753109736af4b8b6.zip
gnu: Add texlive-braids.
* gnu/packages/tex.scm (texlive-braids): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a2e9875871..bd5add6ce4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16378,6 +16378,27 @@ macros, to generate the drawings. As such it can be more flexible than his,
but requires more TikZ knowledge of the user.")
(license license:lppl1.3+)))
+(define-public texlive-braids
+ (package
+ (name "texlive-braids")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/braids/" "source/latex/braids/"
+ "tex/latex/braids/")
+ (base32
+ "1ld7kzr96bh7gdjllxn888j92p7j1l4b1krlp8dmhy6fq3a2qn22")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/braids")
+ (synopsis "Draw Braid diagrams with PGF/TikZ")
+ (description
+ "The package enables drawing of Braid diagrams with PGF/TikZ using
+a simple syntax. The Braid itself is specified by giving a word in the Braid
+group, and there are many options for styling the strands and for drawing
+floors.")
+ (license license:lppl1.3c)))
+
(define-public texlive-gates
(package
(name "texlive-gates")