aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-12 21:54:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:00 +0200
commit36d3ab9e1b126c421ec4f912415198b5a856e4d5 (patch)
tree5a5005b19267f77722c8a81df3924d87757ea0b9 /gnu
parent61ee3ac0b5b700736225ac46bf9239e05e2e9509 (diff)
downloadguix-36d3ab9e1b126c421ec4f912415198b5a856e4d5.tar.gz
guix-36d3ab9e1b126c421ec4f912415198b5a856e4d5.zip
gnu: Add texlive-bondgraphs.
* gnu/packages/tex.scm (texlive-bondgraphs): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d923b0366b..a2e9875871 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16356,6 +16356,28 @@ are preprogrammed for use.")
(description "The package draws bond graphs using PGF and TikZ.")
(license license:lppl1.3+)))
+(define-public texlive-bondgraphs
+ (package
+ (name "texlive-bondgraphs")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/bondgraphs/"
+ "source/latex/bondgraphs/"
+ "tex/latex/bondgraphs/")
+ (base32
+ "1gisr9f2n3mwf2qaqdj9sjmxscrpa9zrb9jm7v5l96ba8kqqw6hx")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/bondgraphs")
+ (synopsis "Draws bond graphs in LaTeX, using PGF/TikZ")
+ (description
+ "The package is used to draw bond graphs in LaTeX. Compared to the
+@code{bondgraph} package this package relies more on TikZ styles and less on
+macros, to generate the drawings. As such it can be more flexible than his,
+but requires more TikZ knowledge of the user.")
+ (license license:lppl1.3+)))
+
(define-public texlive-gates
(package
(name "texlive-gates")