aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-08-26 00:23:35 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 00:33:34 +0100
commit346fb50dd2a20f9fc19082ca4a31fc7631b63dc7 (patch)
treefc87269b7ae6221748918e7445894f384f87006a /gnu
parentd09b78904abad57c3fd8bde6ed36f4961f9dbadc (diff)
downloadguix-346fb50dd2a20f9fc19082ca4a31fc7631b63dc7.tar.gz
guix-346fb50dd2a20f9fc19082ca4a31fc7631b63dc7.zip
gnu: Add go-github-com-libp2p-go-libp2p-asn-util.
* gnu/packages/golang-web.scm (go-github-com-libp2p-go-libp2p-asn-util): New variable. Change-Id: Ieb69266f5d637fcbe6b7b5ef1f687852a1a8df20 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 532a1e82db..dd156aac70 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2689,6 +2689,36 @@ router.")
faster (and only does simple bandwidth metrics).")
(license license:expat)))
+(define-public go-github-com-libp2p-go-libp2p-asn-util
+ (package
+ (name "go-github-com-libp2p-go-libp2p-asn-util")
+ (version "0.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libp2p/go-libp2p-asn-util")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1c94sq43bl1kp04lllcfrfyiy5z3zcfz0s65sm1vgb2s40zrwpr7"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/libp2p/go-libp2p-asn-util"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-golang-org-x-exp))
+ (home-page "https://github.com/libp2p/go-libp2p-asn-util")
+ (synopsis "Golang library for IP to ASN mapping")
+ (description
+ "@code{go-libp2p-asn-util} is a Golang library to lookup the
+@acronym{ASN, Autonomous System Number} for an IP address. It uses the IPv6
+to ASN database downloaded from https://iptoasn.com/. Supports only IPv6
+addresses for now.")
+ (license license:expat)))
+
(define-public go-github-com-libp2p-go-nat
(package
(name "go-github-com-libp2p-go-nat")