aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-10-28 23:28:59 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-12-18 23:28:17 +0900
commit801c930fc63f1077ea4e3d65fd47875ff4e1735e (patch)
treed4d8e729fcb587f63587e9a0ff55cf850e6b253e /gnu
parent3125239d94a7c765107166f50fd46d9fd8d76e3c (diff)
downloadguix-801c930fc63f1077ea4e3d65fd47875ff4e1735e.tar.gz
guix-801c930fc63f1077ea4e3d65fd47875ff4e1735e.zip
gnu: ogre: Use gexps.
* gnu/packages/graphics.scm (ogre) [arguments]: Use gexps. Change-Id: I0e9ebeea06769dc849e9579501ffa44fbd4ebc3b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphics.scm81
1 files changed, 41 insertions, 40 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index c4890610b8..696403f7a5 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1189,46 +1189,47 @@ frames per second (FPS), temperatures, CPU/GPU load and more.")
(base32 "157vpfzivg2wf349glyd0cpbyaw1j3fm4nggban70pghql3x48kb"))))
(build-system cmake-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-before 'configure 'unpack-imgui
- (lambda* (#:key inputs #:allow-other-keys)
- (copy-recursively (assoc-ref inputs "imgui-source")
- "../imgui-source")))
- (add-before 'configure 'pre-configure
- ;; CMakeLists.txt forces a CMAKE_INSTALL_RPATH value. As
- ;; a consequence, we cannot suggest ours in configure flags. Fix
- ;; it.
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* "CMakeLists.txt"
- (("set\\(CMAKE_INSTALL_RPATH .*") "")))))
- #:configure-flags
- (let* ((out (assoc-ref %outputs "out"))
- (runpath
- (string-join (list (string-append out "/lib")
- (string-append out "/lib/OGRE"))
- ";")))
- (list (string-append "-DCMAKE_INSTALL_RPATH=" runpath)
- "-DIMGUI_DIR=../imgui-source"
- "-DOGRE_BUILD_DEPENDENCIES=OFF"
- "-DOGRE_BUILD_TESTS=TRUE"
- "-DOGRE_INSTALL_DOCS=TRUE"
- "-DOGRE_INSTALL_SAMPLES=TRUE"
- "-DOGRE_INSTALL_SAMPLES_SOURCE=TRUE"))))
- (native-inputs `(("doxygen" ,doxygen)
- ("imgui-source" ,(package-source imgui-1.86))
- ("googletest" ,googletest)
- ("pkg-config" ,pkg-config)
- ("python" ,python)))
- (inputs (list freeimage
- freetype
- libxaw
- libxrandr
- libxt
- mesa
- pugixml
- sdl2
- zlib))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'unpack-imgui
+ (lambda _
+ (copy-recursively #$(this-package-native-input "imgui-source")
+ "../imgui-source")))
+ (add-before 'configure 'pre-configure
+ ;; CMakeLists.txt forces a CMAKE_INSTALL_RPATH value. As
+ ;; a consequence, we cannot suggest ours in configure flags. Fix
+ ;; it.
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("set\\(CMAKE_INSTALL_RPATH .*") "")))))
+ #:configure-flags
+ #~(let ((runpath (string-join (list (string-append #$output "/lib")
+ (string-append #$output "/lib/OGRE"))
+ ";")))
+ (list (string-append "-DCMAKE_INSTALL_RPATH=" runpath)
+ "-DIMGUI_DIR=../imgui-source"
+ "-DOGRE_BUILD_DEPENDENCIES=OFF"
+ "-DOGRE_BUILD_TESTS=TRUE"
+ "-DOGRE_INSTALL_DOCS=TRUE"
+ "-DOGRE_INSTALL_SAMPLES=TRUE"
+ "-DOGRE_INSTALL_SAMPLES_SOURCE=TRUE"))))
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("imgui-source" ,(package-source imgui-1.86))
+ ("googletest" ,googletest)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (inputs
+ (list freeimage
+ freetype
+ libxaw
+ libxrandr
+ libxt
+ mesa
+ pugixml
+ sdl2
+ zlib))
(synopsis "Scene-oriented, flexible 3D engine written in C++")
(description
"OGRE (Object-Oriented Graphics Rendering Engine) is a scene-oriented,