aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-23 12:42:07 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:31 +0000
commitfa830bdd095da87214eb49dbf583e508aa8f0ebd (patch)
tree4c305b3694e3bbbbb6f447b9733d2bdaf196bf12 /gnu/packages
parentecae6bb621278763f201259ef49f30804c04e996 (diff)
downloadguix-fa830bdd095da87214eb49dbf583e508aa8f0ebd.tar.gz
guix-fa830bdd095da87214eb49dbf583e508aa8f0ebd.zip
gnu: python-pytest-trio: Update to 0.8.0.
* gnu/packages/python-check.scm (python-pytest-trio): Update to 0.8.0. [native-inputs]: Remove python-pytest-cov. Change-Id: I6efe427aa12d4a4b069ac66370adf0ddcdee95dd
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-check.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 1cb077ce86..f009acacb8 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1384,32 +1384,29 @@ simpler.")
(define-public python-pytest-trio
(package
(name "python-pytest-trio")
- (version "0.7.0")
+ (version "0.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-trio" version))
(sha256
- (base32 "0c8cqf9by2884riksrqymqfp2g1d2d798a2zalcw9hmf34c786y0"))))
+ (base32 "0bmmdyjqj5v4a637i4rzm55crv6v3nj268as6x9nr7m76rixnqw3"))))
(build-system pyproject-build-system)
(arguments
(list
- #:test-flags '(list "-W" "error" "-ra" "-v" "--pyargs"
- "pytest_trio" "--verbose" "--cov" "-k"
- (string-append
- ;; Needs network
- "not test_async_yield_fixture_with_nursery"
- " and not test_try"
- ;; No keyboard interrupt in our build environment.
- " and not test_actual_test"))))
+ ;; Tests are broken, see
+ ;; <https://github.com/python-trio/pytest-trio/issues/84>.
+ #:tests? #f))
(native-inputs
(list python-hypothesis
python-pytest
- python-pytest-cov
python-setuptools
python-wheel))
(propagated-inputs
- (list python-async-generator python-outcome python-pytest python-trio))
+ (list python-async-generator
+ python-outcome
+ python-pytest
+ python-trio))
(home-page "https://github.com/python-trio/pytest-trio")
(synopsis "Pytest plugin for trio")
(description