aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-check.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 1cb077ce86..f009acacb8 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1384,32 +1384,29 @@ simpler.")
(define-public python-pytest-trio
(package
(name "python-pytest-trio")
- (version "0.7.0")
+ (version "0.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-trio" version))
(sha256
- (base32 "0c8cqf9by2884riksrqymqfp2g1d2d798a2zalcw9hmf34c786y0"))))
+ (base32 "0bmmdyjqj5v4a637i4rzm55crv6v3nj268as6x9nr7m76rixnqw3"))))
(build-system pyproject-build-system)
(arguments
(list
- #:test-flags '(list "-W" "error" "-ra" "-v" "--pyargs"
- "pytest_trio" "--verbose" "--cov" "-k"
- (string-append
- ;; Needs network
- "not test_async_yield_fixture_with_nursery"
- " and not test_try"
- ;; No keyboard interrupt in our build environment.
- " and not test_actual_test"))))
+ ;; Tests are broken, see
+ ;; <https://github.com/python-trio/pytest-trio/issues/84>.
+ #:tests? #f))
(native-inputs
(list python-hypothesis
python-pytest
- python-pytest-cov
python-setuptools
python-wheel))
(propagated-inputs
- (list python-async-generator python-outcome python-pytest python-trio))
+ (list python-async-generator
+ python-outcome
+ python-pytest
+ python-trio))
(home-page "https://github.com/python-trio/pytest-trio")
(synopsis "Pytest plugin for trio")
(description