aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-25 09:41:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-25 09:45:30 +0200
commite71dc64e23853b069d861ed1deeeebecda1705e4 (patch)
tree9fe1dcef47cd579d1565a958e71861daedf1fbdf /gnu/packages
parent718223c58c20fa066527fb30da2b5dccca82913f (diff)
downloadguix-e71dc64e23853b069d861ed1deeeebecda1705e4.tar.gz
guix-e71dc64e23853b069d861ed1deeeebecda1705e4.zip
gnu: diffoscope: Use newer llvm.
* gnu/packages/diffoscope.scm (diffoscope)[source]: Remove patch. [native-inputs]: Replace llvm-9 with llvm. * gnu/packages/patches/diffoscope-fix-llvm-test.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/diffoscope.scm8
-rw-r--r--gnu/packages/patches/diffoscope-fix-llvm-test.patch29
2 files changed, 3 insertions, 34 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index cb8e9e01b9..4c88468c3c 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Vagrant Cascadian <vagrant@reproducible-builds.org>
-;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -84,9 +84,7 @@
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1m6fc7k8cd7ahra05vqccw1fdbjj6d20vr3q8v67ynnyih5nmbnb"))
- (patches
- (search-patches "diffoscope-fix-llvm-test.patch"))))
+ (base32 "1m6fc7k8cd7ahra05vqccw1fdbjj6d20vr3q8v67ynnyih5nmbnb"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -193,7 +191,7 @@
hdf5
imagemagick
libarchive
- llvm-9
+ llvm
lz4
lzip
ocaml
diff --git a/gnu/packages/patches/diffoscope-fix-llvm-test.patch b/gnu/packages/patches/diffoscope-fix-llvm-test.patch
deleted file mode 100644
index 1c1c344720..0000000000
--- a/gnu/packages/patches/diffoscope-fix-llvm-test.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From b7eeac09eb068083bdee1a3aa062d1e52a2fa61a Mon Sep 17 00:00:00 2001
-From: Tobias Geerinckx-Rice <me@tobias.gr>
-Date: Mon, 4 Oct 2021 21:03:43 +0200
-Subject: [PATCH] gnu: diffoscope: Fix test_item3_deflate_llvm_bitcode.
-
-Taken verbatim from Nixpkgs[0]. Later extended for diffoscope >= 224.
-
-[0]: https://github.com/NixOS/nixpkgs/blob/589e03f109092a3ba97781fd0533110bf78a3f97/pkgs/tools/misc/diffoscope/fix-tests.patch
----
- tests/comparators/test_rlib.py | 3 ---
- 1 file changed, 3 deletions(-)
-
-diff --git a/tests/comparators/test_rlib.py b/tests/comparators/test_rlib.py
-index 8a20114d..64cea17f 100644
---- a/tests/comparators/test_rlib.py
-+++ b/tests/comparators/test_rlib.py
-@@ -80,12 +80,6 @@ def rlib_dis_expected_diff():
- if actual_ver >= "7.0":
- diff_file = "rlib_llvm_dis_expected_diff_7"
-
-- if actual_ver >= "10.0":
-- diff_file = "rlib_llvm_dis_expected_diff_10"
--
-- if actual_ver >= "15.0":
-- diff_file = "rlib_llvm_dis_expected_diff_15"
--
- return get_data(diff_file)
-
-