aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-01-22 01:49:50 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-25 00:22:53 +0100
commit718223c58c20fa066527fb30da2b5dccca82913f (patch)
tree3c392b34c034b178db712b5bc3f27c9a593a784a /gnu/packages
parented56d2a1c2b289c77174afac0c6b3b3bcae2e7ea (diff)
downloadguix-718223c58c20fa066527fb30da2b5dccca82913f.tar.gz
guix-718223c58c20fa066527fb30da2b5dccca82913f.zip
gnu: Add python-phylophlan.
* gnu/packages/bioinformatics.scm (python-phylophlan): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 063fe7f094..6cb5ea99eb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1103,6 +1103,43 @@ protocol. It provides a simple and reliable way to retrieve genomic data from
servers supporting the protocol.")
(license license:asl2.0)))
+(define-public python-phylophlan
+ (package
+ (name "python-phylophlan")
+ (version "3.0.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/biobakery/phylophlan")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wz70xzxqx2sf5flmf45m15jq027dqijfaj1r51pl50w5x6dkawx"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #f)) ;there are no tests
+ (propagated-inputs
+ (list python-biopython
+ python-dendropy
+ python-matplotlib
+ python-numpy
+ python-pandas
+ python-seaborn))
+ (home-page "https://github.com/biobakery/phylophlan")
+ (synopsis
+ "Phylogenetic analysis of microbial isolates and genomes from metagenomes")
+ (description
+ "This package is an integrated pipeline for large-scale phylogenetic
+profiling of genomes and metagenomes. PhyloPhlAn is an accurate, rapid, and
+easy-to-use method for large-scale microbial genome characterization and
+phylogenetic analysis at multiple levels of resolution. This software package
+can assign both genomes and @acronym{MAGs, metagenome-assembled genomes} to
+@acronym{SGBs, species-level genome bins}. PhyloPhlAn can reconstruct
+strain-level phylogenies using clade- specific maximally informative
+phylogenetic markers, and can also scale to very large phylogenies comprising
+>17,000 microbial species.")
+ (license license:expat)))
+
(define-public python-pybedtools
(package
(name "python-pybedtools")