aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-02 21:55:22 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 17:03:08 +0100
commitd2dc4e67b0e17fd2c6519a1c96eb75d3a1d10dd0 (patch)
treea977d58140a9ba107e4884091673a08bcfce37f8 /gnu/packages
parente95505fbecfc3bc716b708a2581f30226f6ef8c5 (diff)
downloadguix-d2dc4e67b0e17fd2c6519a1c96eb75d3a1d10dd0.tar.gz
guix-d2dc4e67b0e17fd2c6519a1c96eb75d3a1d10dd0.zip
gnu: Add python-pyxsim.
* gnu/packages/astronomy.scm (python-pyxsim): New variable. Change-Id: I65be8702f12f26aed6ed9bff9c246ac3400aa1db
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/astronomy.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 21de65f8d3..6ced811c00 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1196,6 +1196,59 @@ zooming windows, star catalog access, cuts, star pick/FWHM, thumbnails, etc.")
across many files.")
(license license:bsd-3)))
+(define-public python-pyxsim
+ (package
+ (name "python-pyxsim")
+ (version "4.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyxsim" version))
+ (sha256
+ (base32 "1vviy9hk2z3h0fi6c8207ps5pklsjn0a77pqq6wa4sa1n07clc8i"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; XXX: Tests require additional data, check if it may be packed
+ ;; separately, see tests/ci_install.sh.
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'set-home
+ (lambda _
+ ;; To address sanity check warning: UserWarning: unable to write
+ ;; new config file.
+ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs
+ (list python-astropy
+ python-h5py
+ python-numpy
+ python-scipy
+ python-soxs
+ python-tqdm
+ python-unyt
+ python-yt))
+ (native-inputs
+ (list python-cython-3
+ python-setuptools-scm))
+ (home-page "https://hea-www.cfa.harvard.edu/~jzuhone/pyxsim/")
+ (synopsis "Simulating X-ray observations from astrophysical sources")
+ (description
+ "This package implements functionality for simulating X-ray emission from
+astrophysical sources.
+
+X-rays probe the high-energy universe, from hot galaxy clusters to compact
+objects such as neutron stars and black holes and many interesting sources in
+between. pyXSIM makes it possible to generate synthetic X-ray observations of
+these sources from a wide variety of models, whether from grid-based
+simulation codes such as FLASH, Enzo, and Athena, to particle-based codes such
+as Gadget and AREPO, and even from datasets that have been created 'by hand',
+such as from NumPy arrays. pyXSIM also provides facilities for manipulating
+the synthetic observations it produces in various ways, as well as ways to
+export the simulated X-ray events to other software packages to simulate the
+end products of specific X-ray observatories.")
+ (license license:bsd-3)))
+
(define-public python-sncosmo
(package
(name "python-sncosmo")