aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-02 22:20:46 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 17:03:08 +0100
commite95505fbecfc3bc716b708a2581f30226f6ef8c5 (patch)
treea99e98861cf0a7c5ea587e7b607e79944ed9fe4a /gnu/packages
parentcae27fe35ee95e4d54093bde93c5d3f2563f6d26 (diff)
downloadguix-e95505fbecfc3bc716b708a2581f30226f6ef8c5.tar.gz
guix-e95505fbecfc3bc716b708a2581f30226f6ef8c5.zip
gnu: Add python-soxs.
* gnu/packages/astronomy.scm (python-soxs): New variable. Change-Id: Ie5712f2d8d26f78d6eee997689fabaa113b04a9e
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/astronomy.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 451ad9019e..21de65f8d3 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1273,6 +1273,56 @@ across many files.")
to make such analysis both as flexible and clear as possible.")
(license license:bsd-3)))
+(define-public python-soxs
+ (package
+ (name "python-soxs")
+ (version "4.8.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "soxs" version))
+ (sha256
+ (base32 "1m5q3i7hk7jqdpd46h13c4a16b74p0k4mqkxhs43b4vi95h70qrj"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; XXX: Tests require additional data, check if it may be packed
+ ;; separately, see tests/ci_install.sh.
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'set-home
+ (lambda _
+ ;; To address sanity check warning: UserWarning: unable to write
+ ;; new config file.
+ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs
+ (list python-appdirs
+ python-astropy
+ python-h5py
+ python-numpy
+ python-pooch
+ python-pyyaml
+ python-regions
+ python-scipy
+ python-tqdm))
+ (native-inputs
+ (list python-cython
+ python-setuptools-scm))
+ (home-page "https://hea-www.cfa.harvard.edu/soxs/")
+ (synopsis "Simulated Observations of X-ray Sources")
+ (description
+ "SOXS is a software suite which can create simulated X-ray observations
+of astrophysical sources with almost any existing or planned X-ray
+observatory. The goal of SOXS is to provide a comprehensive set of tools to
+design source models and convolve them with simulated models of X-ray
+instruments. This package was originally developed to support the
+@url{https://www.lynxobservatory.org/,Lynx X-ray Observatory} mission concept,
+but has evolved to support other missions as well.")
+ ;; SOXS is licensed under the terms of the Modified BSD License (also
+ ;; known as New or Revised BSD).
+ (license license:bsd-3)))
+
(define-public wcslib
(package
(name "wcslib")