aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-08 10:23:15 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:44 +0000
commitd058b5104ac9b626155062d2696b0b7015023a7b (patch)
treea61c4bab66a82a0fa5cb38cdb4997f3f6da87e8d /gnu/packages
parenta1c132d37ef1294104935dd9ac31e1889f6da16e (diff)
downloadguix-d058b5104ac9b626155062d2696b0b7015023a7b.tar.gz
guix-d058b5104ac9b626155062d2696b0b7015023a7b.zip
gnu: python-myst-parser: Update to 3.0.1.
* gnu/packages/sphinx.scm (python-myst-parser): Update to 3.0.1. [arguments]: Adjust tests; remove extra build phases. Change-Id: I1990d2156958dc437875bf1f7f8b4defc147e58a
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/sphinx.scm26
1 files changed, 6 insertions, 20 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 747c526011..c826617a9f 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -924,8 +924,7 @@ and several other projects.")
(define-public python-myst-parser
(package
(name "python-myst-parser")
- ;; The latest version (v2.0.0) require Sphinx >= v6.
- (version "0.18.1")
+ (version "3.0.1")
(source (origin
(method git-fetch) ;for tests
(uri (git-reference
@@ -934,26 +933,13 @@ and several other projects.")
(file-name (git-file-name name version))
(sha256
(base32
- "0lcz9vvy8hbp6cjmbslrlxn3pinf98jykiq8nx5lw5y0lz0mj162"))))
+ "0lac1mf9pnbmr1jcllhh0sh0y4cnmncx36g2mjbwyd6rm6akbajc"))))
(build-system pyproject-build-system)
(arguments
- ;; There are 3 test failures, seemingly due to expecting a slightly
- ;; different output from Sphinx (see:
- ;; https://github.com/executablebooks/MyST-Parser/issues/645).
- (list #:test-flags #~(list "-k" (string-append
- "not test_basic "
- "and not test_gettext_html "
- "and not test_fieldlist_extension "
- "and not test_syntax_extensions"))
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'relax-requirements
- (lambda _
- (substitute* "pyproject.toml"
- ;; "mdit-py-plugins~=0.3.1"
- (("0.3.1") "0.4.0")
- ;; "markdown-it-py>=1.0.0,<3.0.0"
- (("3.0.0") "4.0.0")))))))
+ (list
+ #:test-flags
+ ;; "Currently only dot format is supported."
+ '(list "--ignore=tests/test_renderers/test_parse_directives.py")))
(native-inputs
(list python-beautifulsoup4
python-docutils