aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-12 22:21:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:07 +0200
commitb7618a44afe539cd3b706d30961b479b4e8c1094 (patch)
tree4e704518ee11e58371223b45e7a01e858ff740e3 /gnu/packages
parent5332693c3cf538825142f397fe49691851de028b (diff)
downloadguix-b7618a44afe539cd3b706d30961b479b4e8c1094.tar.gz
guix-b7618a44afe539cd3b706d30961b479b4e8c1094.zip
gnu: Add texlive-dot2texi.
* gnu/packages/tex.scm (texlive-dot2texi): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a5e535e8e2..7af70e2c83 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16791,6 +16791,27 @@ documentation of PicTeX.")
(list
(license:fsf-free "share/texmf-dist/doc/generic/doc-pictex/Doc-PiCTeX.txt")))))
+(define-public texlive-dot2texi
+ (package
+ (name "texlive-dot2texi")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/dot2texi/" "tex/latex/dot2texi/")
+ (base32
+ "1m8774ds3hsky4nk0krj4a582fyznrxdfbfma5z8hp083nrlm469")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/dot2texi")
+ (synopsis "Create graphs within LaTeX using the @code{dot2tex} tool")
+ (description
+ "The @code{dot2texi} package allows you to embed graphs in the DOT graph
+description language in your LaTeX documents. The @code{dot2tex} tool is used
+to invoke Graphviz for graph layout, and to transform the output from Graphviz
+to LaTeX code. The generated code relies on the TikZ and PGF package or the
+PSTricks package.")
+ (license license:gpl3+)))
+
(define-public texlive-gates
(package
(name "texlive-gates")