aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBrennan Vincent <brennan@umanwizard.com>2024-08-26 13:40:57 -0400
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:04:18 +0200
commit89d6561de9ffff2b24c74418564c1983c187508a (patch)
tree3d2c26198e758b928102d055cd772c5ac779a69f /gnu/packages
parent31fafd227036cf76f861c5582d828842826af097 (diff)
downloadguix-89d6561de9ffff2b24c74418564c1983c187508a.tar.gz
guix-89d6561de9ffff2b24c74418564c1983c187508a.zip
gnu: rust: Update to 1.80.
gnu/packages/rust.scm (rust): Update to 1.80. Change-Id: Ife65cb52362a30df8aabd4255a3fdc3c3d60e7bb Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/rust.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index e0def663b9..016ffced53 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -1064,7 +1064,7 @@ safety and thread safety guarantees.")
;;; Here we take the latest included Rust, make it public, and re-enable tests
;;; and extra components such as rustfmt.
(define-public rust
- (let ((base-rust rust-1.79))
+ (let ((base-rust rust-1.80))
(package
(inherit base-rust)
(properties (append
@@ -1079,7 +1079,7 @@ safety and thread safety guarantees.")
(for-each delete-file-recursively
'("src/llvm-project"
"vendor/jemalloc-sys-0.5.4+5.3.0-patched/jemalloc"
- "vendor/openssl-src-111.28.1+1.1.1w/openssl"
+ "vendor/openssl-src-111.28.2+1.1.1w/openssl"
"vendor/tikv-jemalloc-sys-0.5.4+5.3.0-patched/jemalloc"
;; These are referenced by the cargo output
;; so we unbundle them.
@@ -1100,7 +1100,8 @@ safety and thread safety guarantees.")
(for-each delete-file
(find-files "vendor" "\\.(a|dll|exe|lib)$"))
;; Adjust vendored dependency to explicitly use rustix with libc backend.
- (substitute* "vendor/tempfile/Cargo.toml"
+ (substitute* '("vendor/tempfile-3.7.1/Cargo.toml"
+ "vendor/tempfile-3.10.1/Cargo.toml")
(("features = \\[\"fs\"" all)
(string-append all ", \"use-libc\"")))))))
(arguments
@@ -1210,6 +1211,15 @@ safety and thread safety guarantees.")
(substitute* "src/tools/cargo/tests/testsuite/install.rs"
,@(make-ignore-test-list
'("fn install_global_cargo_config")))))
+ (add-after 'unpack 'disable-miscellaneous-broken-tests
+ (lambda _
+ (substitute* "src/tools/cargo/tests/testsuite/check_cfg.rs"
+ ;; These apparently get confused by the fact that
+ ;; we're building in a directory containing the
+ ;; string "rustc"
+ ,@(make-ignore-test-list
+ '("fn config_fingerprint"
+ "fn features_fingerprint")))))
(add-after 'unpack 'patch-command-exec-tests
;; This test suite includes some tests that the stdlib's
;; `Command` execution properly handles in situations where