aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBrennan Vincent <brennan@umanwizard.com>2024-08-26 13:40:56 -0400
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:04:18 +0200
commit31fafd227036cf76f861c5582d828842826af097 (patch)
tree612b82d467d0e80a1481eedbe565ff8dcc5d8f7f /gnu/packages
parent40d3ae11324a304603e7d9ad026c43e51613eb76 (diff)
downloadguix-31fafd227036cf76f861c5582d828842826af097.tar.gz
guix-31fafd227036cf76f861c5582d828842826af097.zip
gnu: Add rust-1.80.
gnu/packages/rust.scm (rust-1.80): New variable. Change-Id: Ie7dd276f7b4d606660557f3da42064b04dda1435 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/rust.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index c3b06063f7..e0def663b9 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -1023,6 +1023,33 @@ safety and thread safety guarantees.")
(("features = \\[\"fs\"" all)
(string-append all ", \"use-libc\""))))))))))
+(define-public rust-1.80
+ (let ((base-rust (rust-bootstrapped-package rust-1.79 "1.80.1"
+ "1i1dbpwnv6ak244lapsxvd26w6sbas9g4l6crc8bip2275j8y2rc")))
+ (package
+ (inherit base-rust)
+ (source
+ (origin
+ (inherit (package-source base-rust))
+ (snippet
+ '(begin
+ (for-each delete-file-recursively
+ '("src/llvm-project"
+ "vendor/jemalloc-sys-0.5.3+5.3.0-patched/jemalloc"
+ "vendor/jemalloc-sys-0.5.4+5.3.0-patched/jemalloc"
+ "vendor/openssl-src-111.28.2+1.1.1w/openssl"
+ "vendor/tikv-jemalloc-sys-0.5.4+5.3.0-patched/jemalloc"))
+ ;; Remove vendored dynamically linked libraries.
+ ;; find . -not -type d -executable -exec file {} \+ | grep ELF
+ ;; Also remove the bundled (mostly Windows) libraries.
+ (for-each delete-file
+ (find-files "vendor" "\\.(a|dll|exe|lib)$"))
+ ;; Adjust vendored dependency to explicitly use rustix with libc backend.
+ (substitute* '("vendor/tempfile-3.7.1/Cargo.toml"
+ "vendor/tempfile-3.10.1/Cargo.toml")
+ (("features = \\[\"fs\"" all)
+ (string-append all ", \"use-libc\""))))))))))
+
(define (make-ignore-test-list strs)
"Function to make creating a list to ignore tests a bit easier."
(map (lambda (str)