aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-17 23:15:25 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:26 +0000
commit4ccbd13be0ca98b262a63a4ad24d4a82f479d238 (patch)
treed470038cdccfe638aea9a25389e349891dd2ebc1 /gnu/packages
parent1b979d7a1beafc75ef55b87162fec4e78fd8ef82 (diff)
downloadguix-4ccbd13be0ca98b262a63a4ad24d4a82f479d238.tar.gz
guix-4ccbd13be0ca98b262a63a4ad24d4a82f479d238.zip
gnu: Remove python-flask-jwt.
Unmaintained and not in use by any packages in Guix. Upstream note: "This repository has been archived by the owner on Feb 22, 2024. It is now read-only." * gnu/packages/python-web.scm (python-flask-jwt): Delete variable. Change-Id: Id59422744dd0ee81dcde782f6172744ab026bb00
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm32
1 files changed, 0 insertions, 32 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 304d01bfff..069b9ec4ca 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4980,38 +4980,6 @@ Betamax that may possibly end up in the main package.")
"S3transfer is a Python library for managing Amazon S3 transfers.")
(license license:asl2.0)))
-(define-public python-flask-jwt
- (package
- (name "python-flask-jwt")
- (version "0.3.2")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "Flask-JWT" version))
- (sha256
- (base32
- "1bfh7cr0sf65rn4h1q67472y6ml9s8c4k0xxfhrwvwg0plpngh29"))))
- (build-system pyproject-build-system)
- (arguments
- (list
- #:phases
- '(modify-phases %standard-phases
- (add-after 'unpack 'compatibility
- (lambda _
- (substitute* "setup.cfg"
- (("\\[pytest\\]") "[tool:pytest]"))
- (substitute* "requirements.txt"
- (("PyJWT>=1.4.0,<1.5.0") "PyJWT>=2.0.0"))
- (substitute* '("tests/test_jwt.py"
- "flask_jwt/__init__.py")
- (("access_token.decode\\('utf-8'\\)") "access_token")))))))
- (propagated-inputs (list python-flask python-pyjwt))
- (native-inputs (list python-pytest python-setuptools python-wheel))
- (home-page "https://github.com/mattupstate/flask-jwt")
- (synopsis "JWT token authentication for Flask apps")
- (description "This package implements JWT token authentication for Flask
-apps.")
- (license license:expat)))
-
(define-public python-flask-restful
(package
(name "python-flask-restful")
exit (guard (c ((store-protocol-error? c) (->bool (string-contains (pk (store-protocol-error-message c)) "failed")))) (build-derivations store (list drv)) #f))))' for option in --max-silent-time=1 --timeout=1 do guix-daemon --listen="$socket" --disable-chroot "$option" & daemon_pid=$! GUIX_DAEMON_SOCKET="$socket" guile -c "$client_code" kill "$daemon_pid" done # Make sure garbage collection from a TCP connection does not work. tcp_socket="127.0.0.1:9998" guix-daemon --listen="$tcp_socket" & daemon_pid=$! GUIX_DAEMON_SOCKET="guix://$tcp_socket" export GUIX_DAEMON_SOCKET guix gc && false unset GUIX_DAEMON_SOCKET kill "$daemon_pid" # Log compression. guix-daemon --listen="$socket" --disable-chroot --debug --log-compression=gzip & daemon_pid=$! stamp="compressed-build-log-test-$$-`date +%H%M%S`" client_code=" (use-modules (guix) (gnu packages bootstrap)) (with-store store (run-with-store store (mlet %store-monad ((drv (lower-object (computed-file \"compressed-log-test\" #~(begin (display \"$stamp\") (newline) (mkdir #\$output)) #:guile %bootstrap-guile)))) (display (derivation-file-name drv)) (newline) (return #t)))) " GUIX_DAEMON_SOCKET="$socket" export GUIX_DAEMON_SOCKET drv=`guile -c "$client_code"` guix build "$drv" log=`guix build "$drv" --log-file` test -f "$log" case "$log" in *.gz) test "`gunzip -c < "$log"`" = "$stamp" ;; *) false ;; esac