aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-17 23:15:25 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:26 +0000
commit4ccbd13be0ca98b262a63a4ad24d4a82f479d238 (patch)
treed470038cdccfe638aea9a25389e349891dd2ebc1
parent1b979d7a1beafc75ef55b87162fec4e78fd8ef82 (diff)
downloadguix-4ccbd13be0ca98b262a63a4ad24d4a82f479d238.tar.gz
guix-4ccbd13be0ca98b262a63a4ad24d4a82f479d238.zip
gnu: Remove python-flask-jwt.
Unmaintained and not in use by any packages in Guix. Upstream note: "This repository has been archived by the owner on Feb 22, 2024. It is now read-only." * gnu/packages/python-web.scm (python-flask-jwt): Delete variable. Change-Id: Id59422744dd0ee81dcde782f6172744ab026bb00
-rw-r--r--gnu/packages/python-web.scm32
1 files changed, 0 insertions, 32 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 304d01bfff..069b9ec4ca 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4980,38 +4980,6 @@ Betamax that may possibly end up in the main package.")
"S3transfer is a Python library for managing Amazon S3 transfers.")
(license license:asl2.0)))
-(define-public python-flask-jwt
- (package
- (name "python-flask-jwt")
- (version "0.3.2")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "Flask-JWT" version))
- (sha256
- (base32
- "1bfh7cr0sf65rn4h1q67472y6ml9s8c4k0xxfhrwvwg0plpngh29"))))
- (build-system pyproject-build-system)
- (arguments
- (list
- #:phases
- '(modify-phases %standard-phases
- (add-after 'unpack 'compatibility
- (lambda _
- (substitute* "setup.cfg"
- (("\\[pytest\\]") "[tool:pytest]"))
- (substitute* "requirements.txt"
- (("PyJWT>=1.4.0,<1.5.0") "PyJWT>=2.0.0"))
- (substitute* '("tests/test_jwt.py"
- "flask_jwt/__init__.py")
- (("access_token.decode\\('utf-8'\\)") "access_token")))))))
- (propagated-inputs (list python-flask python-pyjwt))
- (native-inputs (list python-pytest python-setuptools python-wheel))
- (home-page "https://github.com/mattupstate/flask-jwt")
- (synopsis "JWT token authentication for Flask apps")
- (description "This package implements JWT token authentication for Flask
-apps.")
- (license license:expat)))
-
(define-public python-flask-restful
(package
(name "python-flask-restful")