aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-08 10:31:21 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:44 +0000
commit3b2f5942d004340fcfe8cdf30124ca0b0c2bf9d1 (patch)
treecef044311877f37c268b8ab4790561a5fc6af706 /gnu/packages
parentd058b5104ac9b626155062d2696b0b7015023a7b (diff)
downloadguix-3b2f5942d004340fcfe8cdf30124ca0b0c2bf9d1.tar.gz
guix-3b2f5942d004340fcfe8cdf30124ca0b0c2bf9d1.zip
gnu: Add python-sphinxext-rediraffe.
* gnu/packages/sphinx.scm (python-sphinxext-rediraffe): New variable. Change-Id: I772993b7bc3a43befc459cc6a9c6d1c90932d341
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/sphinx.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index c826617a9f..b22a288234 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -1071,6 +1071,37 @@ translate and to apply translation to Sphinx generated document.")
"This package provides a Sphinx Extension to generate OG metadata.")
(license license:bsd-3)))
+(define-public python-sphinxext-rediraffe
+ (package
+ (name "python-sphinxext-rediraffe")
+ (version "0.2.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinxext-rediraffe" version))
+ (sha256
+ (base32 "0pbjkwmqc8q08bsk66panvpya831ycjq1ysdagyrznpzwpxcn7b5"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-version
+ (lambda _
+ (substitute* "setup.py"
+ (("version = \"main\"")
+ (string-append "version = \"" #$version "\""))))))))
+ (propagated-inputs (list python-sphinx))
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://github.com/wpilibsuite/sphinxext-rediraffe")
+ (synopsis
+ "Sphinx Extension that redirects non-existent pages to working pages")
+ (description
+ "This sphinx extension redirects non-existent pages to working
+pages. Rediraffe can also check that deleted/renamed files in your git repo
+are redirected.")
+ (license license:expat)))
+
(define-public python-sphinx-autobuild
(package
(name "python-sphinx-autobuild")