aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:30:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:55 +0200
commit32523ddf4d266b18911dc1aa07d375e9cffb2efe (patch)
tree7f13a675009a20e0134aa5bb0e93ea8147a444e0 /gnu/packages
parent145e0bdca38d52a0a25360dab70bfd9c0b52f5c0 (diff)
downloadguix-32523ddf4d266b18911dc1aa07d375e9cffb2efe.tar.gz
guix-32523ddf4d266b18911dc1aa07d375e9cffb2efe.zip
gnu: Add texlive-mathpartir.
* gnu/packages/tex.scm (texlive-mathpartir): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 42c19970fe..f4f1c7063f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4558,6 +4558,33 @@ maths mode.")
;; The license is basically CC-BY.
(license (license:fsf-free "file://tex/generic/mathlig/mathlig.tex"))))
+(define-public texlive-mathpartir
+ (package
+ (name "texlive-mathpartir")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/mathpartir/"
+ "source/latex/mathpartir/"
+ "tex/latex/mathpartir/")
+ (base32
+ "1baadhdxs4rp1qijkwiki2f4w1faarsq3dqy62q7rxs4640mxqa1")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/mathpartir")
+ (synopsis
+ "Typesetting sequences of math formulas, e.g., type inference rules")
+ (description
+ "The package provides macros for typesetting math formulas in mixed
+horizontal and vertical mode, automatically as best fit. It provides an
+environment @code{mathpar} that behaves much as a loose centered paragraph
+where words are math formulas, and spaces between them are larger and
+adjustable. It also provides a macro @code{\\inferrule} for typesetting
+fractions where both the numerator and denominator may be sequences of
+formulas that will be also typeset in a similar way. It can typically be used
+for typeseting sets of type inference rules or typing derivations.")
+ (license license:gpl2)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")