aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:29:48 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:55 +0200
commit145e0bdca38d52a0a25360dab70bfd9c0b52f5c0 (patch)
treeb114b235e4da353933a11e1c172670a9149b57ee /gnu/packages
parent74bac527877274d37aa5e1069dff69ce87d3ce51 (diff)
downloadguix-145e0bdca38d52a0a25360dab70bfd9c0b52f5c0.tar.gz
guix-145e0bdca38d52a0a25360dab70bfd9c0b52f5c0.zip
gnu: Add texlive-mathlig.
* gnu/packages/tex.scm (texlive-mathlig): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a67e3d42ae..42c19970fe 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4540,6 +4540,24 @@ spacing around fractions and roots, math symbols within bold text as well as
capital Greek letters. It also adds some related macros.")
(license license:lppl1.3+)))
+(define-public texlive-mathlig
+ (package
+ (name "texlive-mathlig")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "tex/generic/mathlig/")
+ (base32
+ "0pyaqwr2h9knxf1axi55vm6wr9xj15d5j5pagb2011k3b830f91b")))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/mathlig")
+ (synopsis "Define maths ligatures")
+ (description
+ "The package defines character sequences that behave like ligatures, in
+maths mode.")
+ ;; The license is basically CC-BY.
+ (license (license:fsf-free "file://tex/generic/mathlig/mathlig.tex"))))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")
d>Ludovic Courtès 2021-12-12services: Define '%qemu-static-networking'....* gnu/services/base.scm (%qemu-static-networking): New variable. * gnu/system/hurd.scm (%base-services/hurd): Use it. * doc/guix.texi (Networking Setup): Document it. Ludovic Courtès 2021-12-12services: static-networking: Change interface to mimic netlink....* gnu/services/base.scm (<static-networking>)[interface, ip, netmask] [gateway]: Remove. [addresses, links, routes]: New fields. [requirement]: Default to '(udev). (<network-address>, <network-link>, <network-route>): New record types. (ensure-no-separate-netmask, %ensure-no-separate-netmask): Remove. (ipv6-address?, cidr->netmask, ip+netmask->cidr) (network-set-up/hurd, network-tear-down/hurd) (network-set-up/linux, network-tear-down/linux) (static-networking->hurd-pfinet-options): New procedures. (static-networking-shepherd-service): New procedure. (static-networking-shepherd-services): Rewrite in terms of the above. (static-networking-service): Deprecate. Adjust to new 'static-networking' API. (%base-services): Likewise. * gnu/system/install.scm (%installation-services): Likewise. * gnu/system/hurd.scm (%base-services/hurd): Likewise, and separate 'loopback' from 'networking'. * gnu/build/hurd-boot.scm (set-hurd-device-translators): Remove "servers/socket/2". * gnu/tests/networking.scm (run-openvswitch-test)["networking has started on ovs0"]: Check for 'networking instead of 'networking-ovs0, which is no longer provided. * doc/guix.texi (Networking Setup): Document the new interface. Remove documentation of 'static-networking-service'. (Virtualization Services): Change Ganeti example to use the new interface. Ludovic Courtès 2021-10-18system: hurd: Add 'info-reader' to %BASE-PACKAGES/HURD....* gnu/system/hurd.scm (%base-packages/hurd): Add INFO-READER. Ludovic Courtès 2021-08-29Migrate to the new 'targets' field of bootloader-configuration....The old 'target' field is deprecated; adjust the sources to use the new 'targets' one instead. * doc/guix-cookbook.texi<target>: Replace by 'targets'. * gnu/bootloader/grub.scm: Likewise. * gnu/installer/parted.scm: Likewise. * gnu/machine/digital-ocean.scm: Likewise. * gnu/system/examples/asus-c201.tmpl: Likewise * gnu/system/examples/bare-bones.tmpl: Likewise * gnu/system/examples/bare-hurd.tmpl: Likewise * gnu/system/examples/beaglebone-black.tmpl: Likewise * gnu/system/examples/desktop.tmpl: Likewise * gnu/system/examples/docker-image.tmpl: Likewise * gnu/system/examples/lightweight-desktop.tmpl: Likewise * gnu/system/examples/vm-image.tmpl: Likewise * gnu/system/examples/yggdrasil.tmpl: Likewise * gnu/system/hurd.scm: Likewise * gnu/system/images/hurd.scm: Likewise * gnu/system/images/novena.scm: Likewise * gnu/system/images/pine64.scm: Likewise * gnu/system/images/pinebook-pro.scm: Likewise * gnu/system/images/rock64.scm: Likewise * gnu/system/install.scm: Likewise * gnu/system/vm.scm: Likewise * gnu/tests.scm: Likewise * gnu/tests/ganeti.scm: Likewise * gnu/tests/install.scm: Likewise * gnu/tests/nfs.scm: Likewise * gnu/tests/telephony.scm: Likewise * tests/boot-parameters.scm: Likewise * tests/system.scm: Likewise Maxim Cournoyer 2021-08-12system: install, hurd: Use 'setuid-programs'....This is a followup to a7ac19851baab3fbcc40c4b2cf5b00a6ac9cd2f3. * gnu/system/install.scm (installation-os)[setuid-programs]: Use 'setuid-program'. * gnu/system/hurd.scm (%setuid-programs/hurd): Use 'file-like->setuid-program'. Ludovic Courtès 2021-02-22system: hurd: Have the static networking provision 'networking....Some services require networking, I'm looking at the Guix Build Coordinator agent. Networking seems to work in the childhurd VM, so I think this change makes sense. * gnu/system/hurd.scm (%base-services/hurd): Add 'networking to the provision parameter for the static-networking service. Christopher Baines