aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBrennan Vincent <brennan@umanwizard.com>2024-08-26 13:40:55 -0400
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:04:18 +0200
commit40d3ae11324a304603e7d9ad026c43e51613eb76 (patch)
treec1bfecf6aabdf64c420bd8edfe39f2a193f7a213 /gnu/packages
parentd3f5963b7ce4b06d4aa0f3fa4119fd6c3f5f46e3 (diff)
downloadguix-40d3ae11324a304603e7d9ad026c43e51613eb76.tar.gz
guix-40d3ae11324a304603e7d9ad026c43e51613eb76.zip
gnu: rust: Update to 1.79.
* gnu/packages/rust.scm (rust): Update to 1.79. [source]: Adjust snippet of removed bundled sources. Change-Id: Ic43b4c540413a0e1a08d46cca5a092badc221753 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/rust.scm26
1 files changed, 14 insertions, 12 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index bfc941abb8..c3b06063f7 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -1037,7 +1037,7 @@ safety and thread safety guarantees.")
;;; Here we take the latest included Rust, make it public, and re-enable tests
;;; and extra components such as rustfmt.
(define-public rust
- (let ((base-rust rust-1.78))
+ (let ((base-rust rust-1.79))
(package
(inherit base-rust)
(properties (append
@@ -1051,19 +1051,18 @@ safety and thread safety guarantees.")
'(begin
(for-each delete-file-recursively
'("src/llvm-project"
- "vendor/jemalloc-sys/jemalloc"
- "vendor/openssl-src/openssl"
- "vendor/tikv-jemalloc-sys/jemalloc"
+ "vendor/jemalloc-sys-0.5.4+5.3.0-patched/jemalloc"
+ "vendor/openssl-src-111.28.1+1.1.1w/openssl"
+ "vendor/tikv-jemalloc-sys-0.5.4+5.3.0-patched/jemalloc"
;; These are referenced by the cargo output
;; so we unbundle them.
- "vendor/curl-sys/curl"
- "vendor/libffi-sys/libffi"
- "vendor/libnghttp2-sys/nghttp2"
- "vendor/libz-sys/src/zlib"
- "vendor/libz-sys-1.1.12/src/zlib"))
+ "vendor/curl-sys-0.4.72+curl-8.6.0/curl"
+ "vendor/libffi-sys-2.3.0/libffi"
+ "vendor/libnghttp2-sys-0.1.9+1.58.0/nghttp2"
+ "vendor/libz-sys-1.1.16/src/zlib"))
;; Use the packaged nghttp2
- (delete-file "vendor/libnghttp2-sys/build.rs")
- (with-output-to-file "vendor/libnghttp2-sys/build.rs"
+ (delete-file "vendor/libnghttp2-sys-0.1.9+1.58.0/build.rs")
+ (with-output-to-file "vendor/libnghttp2-sys-0.1.9+1.58.0/build.rs"
(lambda _
(format #t "fn main() {~@
println!(\"cargo:rustc-link-lib=nghttp2\");~@
@@ -1101,7 +1100,10 @@ safety and thread safety guarantees.")
(lambda _
(substitute* "src/tools/cargo/tests/testsuite/git.rs"
,@(make-ignore-test-list
- '("fn fetch_downloads_with_git2_first_")))))
+ '("fn fetch_downloads_with_git2_first_")))
+ (substitute* "src/tools/cargo/tests/testsuite/build.rs"
+ ,@(make-ignore-test-list
+ '("fn build_with_symlink_to_path_dependency_with_build_script_in_git")))))
(add-after 'unpack 'disable-tests-requiring-mercurial
(lambda _
(with-directory-excursion "src/tools/cargo/tests/testsuite/cargo_init"