aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:30:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:48:35 +0200
commitb168a3e9b53c7ab8e7dea48c7d3d46558ef93c11 (patch)
tree2f89e023c58c2cd49e66b281b4bce31098fa9a0a /gnu/packages/tex.scm
parente6fef2fe856b5f95229e5926146d1186880e6782 (diff)
downloadguix-b168a3e9b53c7ab8e7dea48c7d3d46558ef93c11.tar.gz
guix-b168a3e9b53c7ab8e7dea48c7d3d46558ef93c11.zip
gnu: Add texlive-chordbars.
* gnu/packages/tex.scm (texlive-chordbars): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b6f31e63e8..7d796d5cbb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4190,6 +4190,28 @@ given by Mumbai University.")
(license:fsf-free "file://doc/latex/aalok/README.txt")
license:fdl1.3+))))
+(define-public texlive-chordbars
+ (package
+ (name "texlive-chordbars")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/chordbars/"
+ "tex/latex/chordbars/")
+ (base32
+ "0pyxnjalrmkan3mjir6w3g3xhgyzzbjkjhxz460p1nm8n5ng05xq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/chordbars")
+ (synopsis "Print chord grids for pop/jazz tunes")
+ (description
+ "This Tikz-based music-related package is targeted at pop/jazz
+guitar/bass/piano musicians. They usually need only the chords and the song
+structure. This package produces rectangular song patterns with one square
+per bar, with the chord shown inside the square. It also handles the song
+structure by showing the bar count and the repetitions of the patterns.")
+ (license license:lppl1.3+)))
+
(define-public texlive-chronosys
(package
(name "texlive-chronosys")