aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:29:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 09:48:35 +0200
commite6fef2fe856b5f95229e5926146d1186880e6782 (patch)
tree3399fc062625722d1f02f82ad648e18f7b295d17 /gnu/packages/tex.scm
parent497463fb299a13e48f6b348842f2c41f0fd59428 (diff)
downloadguix-e6fef2fe856b5f95229e5926146d1186880e6782.tar.gz
guix-e6fef2fe856b5f95229e5926146d1186880e6782.zip
gnu: Add texlive-bagpipe.
* gnu/packages/tex.scm (texlive-bagpipe): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d858d4998a..b6f31e63e8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2721,6 +2721,25 @@ in-line BNF expressions using math mode.")
@file{hline.ttf} (headline).")
(license license:expat)))
+(define-public texlive-bagpipe
+ (package
+ (name "texlive-bagpipe")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/bagpipe/"
+ "tex/generic/bagpipe/")
+ (base32
+ "0zybnikkj00hmlzfaaljcq1ml5vi6qfhl1hfrjq9vjc409vzzvka")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/bagpipe")
+ (synopsis "Support for typesetting bagpipe music")
+ (description
+ "Typesetting bagpipe music in MusixTeX is needlessly tedious. This
+package provides specialized and re-defined macros to simplify this task.")
+ (license license:lppl1.3+)))
+
(define-public texlive-bangla
(package
(name "texlive-bangla")