aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-10-10 09:55:50 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-10-10 11:41:49 +0300
commit9c2c524daf328858984c7e8cf24330e677dbadd3 (patch)
treec0b9f3971170f9a1b33973c55ea6a9c612fc61fc /gnu/packages/qt.scm
parent96412f34181ed5212fd16d5e32a3e6b9173a8645 (diff)
downloadguix-9c2c524daf328858984c7e8cf24330e677dbadd3.tar.gz
guix-9c2c524daf328858984c7e8cf24330e677dbadd3.zip
gnu: qtcharts, qtdatavis3d: Update license information.
* gnu/packages/qt.scm (qtcharts, qtdatavis3d)[license]: New field.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index c8dc5081da..cc8ba3fc14 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1264,7 +1264,8 @@ drawing calls from Qt Quick JavaScript.")))
components. It uses the Qt Graphics View Framework, therefore charts can be
easily integrated to modern user interfaces. Qt Charts can be used as QWidgets,
QGraphicsWidget, or QML types. Users can easily create impressive graphs by
-selecting one of the charts themes.")))
+selecting one of the charts themes.")
+ (license license:gpl3)))
(define-public qtdatavis3d
(package (inherit qtsvg)
@@ -1290,7 +1291,8 @@ selecting one of the charts themes.")))
data in 3D as bar, scatter, and surface graphs. It is especially useful for
visualizing depth maps and large quantities of rapidly changing data, such as
data received from multiple sensors. The look and feel of graphs can be
-customized by using themes or by adding custom items and labels to them.")))
+customized by using themes or by adding custom items and labels to them.")
+ (license license:gpl3)))
(define-public qtnetworkauth
(package (inherit qtsvg)
717437aa27d9d33fd223a6411f'>daemon: Sacrifice builders on OOM.Tobias Geerinckx-Rice * nix/libstore/build.cc (DerivationGoal::runChild): Maximise our OOM score adjustment. Change-Id: I418c763b499ca16e1ffe3c6033319112b9744f51 2023-12-11daemon: Implement ‘substitute-urls’ RPC.Ludovic Courtès * nix/libstore/worker-protocol.hh (PROTOCOL_VERSION): Bump. (WorkerOp): Add ‘wopSubstituteURLs’. * nix/nix-daemon/nix-daemon.cc (performOp): Implement it. * guix/store.scm (%protocol-version): Bump. (operation-id): Add ‘substitute-urls’. (substitute-urls): New procedure. * tests/store.scm ("substitute-urls, default") ("substitute-urls, client-specified URLs") ("substitute-urls, disabled"): New tests. Change-Id: I2c0119500c3a1eecfa5ebf32463ffb0f173161de 2023-12-04daemon: Simplify “empty status” substitute error message.Ludovic Courtès * nix/libstore/build.cc (SubstitutionGoal::finished): Don’t show what the empty status looks like. Change-Id: Ie898432aeb047aff3d59024de6ed6d18f68903c4 2023-09-24Revert "build: Add missing guix-gc.timer file to binary tarball."Tobias Geerinckx-Rice This reverts commit 69f6edc1a8596d2cb4c67e0435d35633af6f3cbc. The intention is good, but nodist_systemdservice_DATA are meant to be disposable artefacts generated from corresponding ‘.in’ files. etc/guix-gc.timer doesn't fit that description, breaking builds: $ make clean && make … make[2]: *** No rule to make target 'etc/guix-gc.timer', needed by 'all-am'. Stop. 2023-09-26daemon: Add “git-download” built-in builder.Ludovic Courtès The new builder makes it possible to break cycles that occurs when the fixed-output derivation for the source of a dependency of ‘git’ would itself depend on ‘git’. * guix/scripts/perform-download.scm (perform-git-download): New procedure. (perform-download): Move fixed-output derivation check to… (guix-perform-download): … here. Invoke ‘perform-download’ or ‘perform-git-download’ depending on what ‘derivation-builder’ returns. * nix/libstore/builtins.cc (builtins): Add “git-download”. * tests/derivations.scm ("built-in-builders"): Update. ("'git-download' built-in builder") ("'git-download' built-in builder, invalid hash") ("'git-download' built-in builder, invalid commit") ("'git-download' built-in builder, not found"): New tests. 2023-09-09daemon: Fix build with GCC 13.Sören Tempel The sqlite.hh file uses fixed-width integer types from stdint.h. As such, it needs to include <cstdint>. Without this include, the file doesn't compile successfully with GCC13. See: https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes * nix/libstore/sqlite.hh: include <cstdint> Signed-off-by: Sören Tempel <soeren@soeren-tempel.net> Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2023-08-31build: Add missing guix-gc.timer file to binary tarball.Maxim Cournoyer Partially fixes <https://issues.guix.gnu.org/65117>. * nix/local.mk (nodist_systemdservice_DATA): Add etc/guix-gc.timer. 2023-01-09daemon: Improve error message for wrong hash sizes.Ludovic Courtès * nix/libutil/hash.cc (parseHash): Show the hash algorithm name and expected size in the error message. * tests/derivations.scm ("fixed-output derivation, invalid hash size"): New test. 2022-12-18daemon: Make "opening file" error messages distinguishable.Ludovic Courtès * nix/libstore/build.cc (DerivationGoal::openLogFile): Customize "opening file" error message. * nix/libutil/hash.cc (hashFile): Likewise. * nix/libutil/util.cc (readFile, writeFile): Likewise. 2022-10-17Revert "nix: Guard against removing temporary roots of living processes."Ludovic Courtès This reverts commit bb0beaecdee1a2315a1269b1746d238c8ab0e699. This change broke a number of tests that assumed the previous behavior. 2022-10-07nix: Guard against removing temporary roots of living processes.Ludovic Courtès Fixes <https://issues.guix.gnu.org/25018>. * nix/libstore/gc.cc (readTempRoots): Add a check to guard against removing the temporary roots of a living process. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> 2022-09-11daemon: Remove unused function findOutput.Maxime Devos * nix/libstore/misc.cc (findOutput): Remove it. * nix/libstore/misc.hh (findOutput): Likewise. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> 2022-09-11daemon: Remove unused function exportPaths.Maxime Devos * nix/libstore/store-api.cc (exportPaths): Remove it. * nix/libstore/store-api.hh (exportPaths): Likewise. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> 2022-09-11daemon: Remove unused function openStore.Maxime Devos * nix/libstore/store-api.cc (openStore): Remove it. * nix/libstore/store-api.hh (openStore): Likewise. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>