aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-01 20:41:42 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:41 +0000
commitc4e1b63cc9dfc919c9444fb733731ba65ac690b1 (patch)
treeeaee949e799caf37ac222ce663f1deaf6ff4e622 /gnu/packages/python-xyz.scm
parent3b4713e4f30ca2e09de0e5c8e33549318d5b90fb (diff)
downloadguix-c4e1b63cc9dfc919c9444fb733731ba65ac690b1.tar.gz
guix-c4e1b63cc9dfc919c9444fb733731ba65ac690b1.zip
gnu: python-progressbar2: Update to 4.5.0.
* gnu/packages/python-xyz.scm (python-progressbar2): Update to 4.5.0. [build-system]: Swap to pyproject-build-system. [argumetns]<test-flags>: Add bare minimal tests options to make them work. <phases>: Add 'fix-pytest-config. [propagated-inputs]: Remove python-six. [native-inputs]: Remove python-flake8, python-pycodestyle, python-pytest-cache, python-pytest-cov, python-pytest-flakes, python-pytest-pep8, and python-sphinx; add python-dill, python-setuptools, python-setuptools-scm, and python-wheel. Change-Id: Ia0771e92753f991471e63d7270803ca885382917
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 20 insertions, 14 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6a9b2fe825..468d3c61c7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19481,27 +19481,33 @@ character, and suffix.")
(define-public python-progressbar2
(package
(name "python-progressbar2")
- (version "3.51.3")
+ (version "4.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "progressbar2" version))
(sha256
- (base32
- "0b2v3mim90rmfvixkaniz2qrs650sk230rzgd5zhcjfldmlqgxpc"))))
- (build-system python-build-system)
- (propagated-inputs
- (list python-six python-utils))
+ (base32 "1yw8j3sz9y3nw2x1ffiqqzml8l9vb0kixxnsjkmk3vc691icnqk6"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags #~(list "--pyargs" "progressbar" "tests")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-pytest-config
+ (lambda _
+ ;; Drop test coverage requirements.
+ (substitute* "pytest.ini"
+ ((".*-cov.*") "")))))))
(native-inputs
- (list python-flake8
- python-freezegun
- python-pycodestyle
+ (list python-dill
python-pytest
- python-pytest-cache
- python-pytest-cov
- python-pytest-flakes
- python-pytest-pep8
- python-sphinx))
+ python-freezegun
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
+ (propagated-inputs
+ (list python-utils))
(home-page "https://github.com/WoLpH/python-progressbar")
(synopsis "Text progress bar library for Python")
(description