aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-01 20:41:52 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:40 +0000
commit3b4713e4f30ca2e09de0e5c8e33549318d5b90fb (patch)
tree86ed1936d3b77b2b91f30873441ed2d44f7aca52 /gnu/packages/python-xyz.scm
parent8062b35b36c94ebd8b3c4a656cc65ad2b16e5631 (diff)
downloadguix-3b4713e4f30ca2e09de0e5c8e33549318d5b90fb.tar.gz
guix-3b4713e4f30ca2e09de0e5c8e33549318d5b90fb.zip
gnu: python-utils: Update to 3.9.1.
* gnu/packages/python-xyz.scm (python-utils): Update to 3.9.1. [source]: Adjust URI name as PyPI archive has been changed. [build-system]: Swap to pyproject-build-system. [arguments]<phases>: Add 'fix-pytest-config and use default 'check. [propagated-inputs]: Add python-loguru and python-typing-extensions. [native-inputs]: Remove labels. Remove python-pytest-runner and python-six; add python-setuptools and python-wheel. [description]: Fix fill column. Change-Id: I0365e3753e411363f117a35e972ff3e738ddb1ea
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm44
1 files changed, 24 insertions, 20 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f56dff9073..6a9b2fe825 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25392,31 +25392,35 @@ point is the point of maximum curvature.")
(define-public python-utils
(package
(name "python-utils")
- (version "2.4.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "python-utils" version))
- (sha256
- (base32
- "12c0glzkm81ljgf6pwh0d4rmdm1r7vvgg3ifzp8yp9cfyngw07zj"))))
- (build-system python-build-system)
+ (version "3.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python_utils" version))
+ (sha256
+ (base32 "18292j4p1bvlpbrfj2cgkdby6dpgnl5gbjwly0qb4pj1j914nmzb"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (delete-file "pytest.ini")
- (invoke "pytest" "-vv"))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-pytest-config
+ (lambda _
+ ;; Drop test coverage requirements.
+ (substitute* "pytest.ini"
+ ((".*--cov.*") "")))))))
(native-inputs
- `(("pytest-runner" ,python-pytest-runner)
- ("pytest" ,python-pytest)
- ("six" ,python-six)))
+ (list python-pytest
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-loguru
+ python-typing-extensions))
(home-page "https://github.com/WoLpH/python-utils")
(synopsis "Convenient utilities not included with the standard Python install")
(description
- "Python Utils is a collection of small Python functions and classes which
- make common patterns shorter and easier.")
+ "Python Utils is a collection of small Python functions and classes
+which make common patterns shorter and easier.")
(license license:bsd-2)))
(define-public python-diff-cover