aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-01 09:54:49 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:39 +0000
commit66be2df8411a876b0fd306c8789519349c69bd0e (patch)
treeda20131e8959c6786451af3b1091bdf3355aff5e /gnu/packages/python-xyz.scm
parent5d886f8bf59f3fb6a7754335a779eac6ae49637b (diff)
downloadguix-66be2df8411a876b0fd306c8789519349c69bd0e.tar.gz
guix-66be2df8411a876b0fd306c8789519349c69bd0e.zip
gnu: python-flake8-pie: Update to 24.9.0.
* gnu/packages/python-xyz.scm (python-flake8-pie): Update to 24.9.0. [build-system]: Swap to pyproject-build-system. [arguments]<test-flags>: Disable just 2 failing tests. [propagated-inputs]: Add python-attrs, python-flake8, and python-pyflakes. [native-inputs]: Add python-hatchling and python-pytest. Change-Id: Ife6dfef657996497356c4a0d62b2097702bd2024
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 20 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fa4693cf16..e0d48367e7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15505,17 +15505,34 @@ expressions after the entire file has been read. This enables support for
first-class forward references that stub files use.")
(license license:expat)))
+;; XXX: Deprecated in upstream: This repository has been archived by the owner
+;; on Nov 30, 2024. It is now read-only.
+;; Consider to remove when nothing is depend on it.
(define-public python-flake8-pie
(package
(name "python-flake8-pie")
- (version "0.5.0")
+ (version "0.16.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "flake8-pie" version))
(sha256
- (base32 "0kgipl5gljlp7aa7ykx15pswpzkd0d0qiznihb2z0d9a73181dyd"))))
- (build-system python-build-system)
+ (base32 "1fhmwm8blimnfmi1cj8q0kqd77vskgjb794jbp837yh64ywvgp5q"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~(list "-k" "not test_examples and not test_prefer_simple_any_all")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'use-poetry-core
+ (lambda _
+ ;; Patch to use the core poetry API.
+ (substitute* "pyproject.toml"
+ (("poetry.masonry.api") "poetry.core.masonry.api")))))))
+ (native-inputs
+ (list python-poetry-core
+ python-pytest))
(home-page "https://github.com/sbdchd/flake8-pie")
(synopsis "Flake8 extension that implements lints")
(description