aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-01 09:46:08 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:39 +0000
commit5d886f8bf59f3fb6a7754335a779eac6ae49637b (patch)
tree998ac55ad083a99537e57f5b75ade043094e0722 /gnu/packages/python-xyz.scm
parent4d77076ceddbb5f607d9a515039c83de72f006cd (diff)
downloadguix-5d886f8bf59f3fb6a7754335a779eac6ae49637b.tar.gz
guix-5d886f8bf59f3fb6a7754335a779eac6ae49637b.zip
gnu: python-flake8-pyi: Update to 24.9.0.
* gnu/packages/python-xyz.scm (python-flake8-pyi): Update to 24.9.0. Improve style. [source]: Adjust URI name as PyPI archive has been changed. [build-system]: Swap to pyproject-build-system. [arguments]<phases>: Add 'fix-pytest-config. [native-inputs]: Add python-hatchling and python-pytest. [description]: Adjust fill column. Change-Id: Idcc3e9f6213b00e02bc052101a2b666460943de5
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 23 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5826158891..fa4693cf16 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15468,24 +15468,36 @@ files.")
(define-public python-flake8-pyi
(package
(name "python-flake8-pyi")
- (version "20.10.0")
+ (version "24.9.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "flake8-pyi" version))
+ (uri (pypi-uri "flake8_pyi" version))
(sha256
- (base32
- "0b27n2pmrxcc7nva4wp2i7mrag0fnq0firvhg1ljq593a45b5qyf"))))
- (build-system python-build-system)
+ (base32 "1n8cqbqq9cfyn952kwqqs4s7lcyycgr829ymxnplg0cm49877yv4"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-pytest-config
+ (lambda _
+ ;; Prevent full threads utilization.
+ (substitute* "pyproject.toml"
+ (("-nauto") "")))))))
+ (native-inputs
+ (list python-hatchling
+ python-pytest))
(propagated-inputs
- (list python-attrs python-flake8 python-pyflakes))
+ (list python-attrs
+ python-flake8
+ python-pyflakes))
(home-page "https://github.com/ambv/flake8-pyi")
- (synopsis
- "Flake8 plugin that provides specializations for type hinting stub files")
+ (synopsis "Flake8 plugin that provides specializations for type hinting stub files")
(description
- "This package contains a plugin that provides specializations for
-type hinting stub files, especially interesting for linting typeshed. It
-adds the @file{.pyi} extension to the default value of the @code{--filename}
+ "This package contains a plugin that provides specializations for type
+hinting stub files, especially interesting for linting typeshed. It adds the
+@file{.pyi} extension to the default value of the @code{--filename}
command-line argument to Flake8. This means stubs are linted by default with
this plugin enabled, without needing to explicitly list every file. It
modifies PyFlakes runs for @file{.pyi} files to defer checking type annotation