aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-06-15 08:36:12 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-06-18 22:17:56 -0400
commit58949b72ce34cab833d95ff0f1b8799803564834 (patch)
treea4c2a8b2ae8fe340b881f814e5bf14203af73e67 /gnu/packages/python-xyz.scm
parentbf9afedef9c55aa0092b562077d9f2c743d9a29c (diff)
downloadguix-58949b72ce34cab833d95ff0f1b8799803564834.tar.gz
guix-58949b72ce34cab833d95ff0f1b8799803564834.zip
gnu: python-pyzmq: Reinstate two tests.
* gnu/packages/python-xyz.scm (python-pyzmq) [arguments]: Reinstate the test_auth and test_zmqstream tests, fixed in the last 25.1.0 version.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 1 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cdffc3ad67..81d3ec5d95 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11879,11 +11879,7 @@ applications.")
(lambda _
;; FIXME: The test_draft.TestDraftSockets test fails with:
;; zmq.error.Again: Resource temporarily unavailable
- (delete-file "zmq/tests/test_draft.py")
- ;; These tests appear to depend on a working name resolver (see:
- ;; https://github.com/zeromq/pyzmq/issues/1853).
- (delete-file "zmq/tests/test_auth.py")
- (delete-file "zmq/tests/test_zmqstream.py")))
+ (delete-file "zmq/tests/test_draft.py")))
(add-before 'check 'build-extensions
(lambda _
;; Cython extensions have to be built before running the tests.