aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-11-19 15:21:53 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-19 15:26:51 +0000
commit20ecc8b5a995dd782891dcfe213dd3c67295fe30 (patch)
tree9ce255d0017ab2b66eb65144708a6059e0930a34 /gnu/packages/python-xyz.scm
parent3f6691b77bccc13c5038232c77f7f1bb780e1de5 (diff)
downloadguix-20ecc8b5a995dd782891dcfe213dd3c67295fe30.tar.gz
guix-20ecc8b5a995dd782891dcfe213dd3c67295fe30.zip
gnu: python-boto3: Respect --cores build argument.
This commit ensures that a user-provided --cores argument to guix build is respected. * gnu/packages/python-xyz.scm (python-boto3)[arguments] <#:test-flags>: Replace "auto" numprocesses by parallel-job-count. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5d2510cb23..4bfdfc2c5d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19379,7 +19379,7 @@ Amazon Web Services (AWS) API.")
(arguments
(list
#:test-flags
- #~(list "--numprocesses" "auto"
+ #~(list "--numprocesses" (number->string (parallel-job-count))
;; Integration tests are trying to connect to AWS.
"--ignore" "tests/integration")))
(native-inputs