aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-11-19 15:21:52 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-19 15:26:50 +0000
commit3f6691b77bccc13c5038232c77f7f1bb780e1de5 (patch)
tree2795498a1ffdf24c0779e9367bd7621357da60be /gnu/packages/python-xyz.scm
parent304a6deaeb42c24488d909641aeb72ddcf2b6a02 (diff)
downloadguix-3f6691b77bccc13c5038232c77f7f1bb780e1de5.tar.gz
guix-3f6691b77bccc13c5038232c77f7f1bb780e1de5.zip
gnu: python-botocore: Respect --cores build argument.
This commit ensures that a user-provided --cores argument to guix build is respected. * gnu/packages/python-xyz.scm (python-botocore)[arguments] <#:test-flags>: Replace "auto" numprocesses by parallel-job-count. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c7d2efe79f..5d2510cb23 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19340,7 +19340,7 @@ browser from Python.")
(arguments
(list
#:test-flags
- #~(list "--numprocesses" "auto"
+ #~(list "--numprocesses" (number->string (parallel-job-count))
;; It strugles to find 'botocore'.
"--ignore" "tests/functional/leak/test_resource_leaks.py"
;; Tests require networking.