aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-07 21:55:24 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:06 +0000
commit43bd54aafc459131af72c1b4c78782f0b98a6f4a (patch)
treebd5f61f377b1d65f72f69610c3486858d8a57baf /gnu/packages/python-web.scm
parentc76bec3d93bc5008618fb0b9ff26f0e0f4323d18 (diff)
downloadguix-43bd54aafc459131af72c1b4c78782f0b98a6f4a.tar.gz
guix-43bd54aafc459131af72c1b4c78782f0b98a6f4a.zip
gnu: python-pysolr: Update to 3.10.0.
* gnu/packages/python-web.scm (python-pysolr): Update to 3.10.0. Fix indentation. [build-system]: Swap to pyproject-build-system. [native-inputs]: Add python-pytest, python-setuptools, and python-wheel. Change-Id: I9816a58db835ba104952c3d9e189c32947f57698
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8095b27b8b..efa2e3e14b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7683,21 +7683,22 @@ wrapping the @code{requests} Python library.")
(define-public python-pysolr
(package
(name "python-pysolr")
- (version "3.9.0")
+ (version "3.10.0")
(source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pysolr" version))
- (sha256
- (base32
- "1rj5jmscvxjwcmlfi6hmkj44l4x6n3ln5p7d8d18j566hzmmzw3f"))))
- (build-system python-build-system)
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pysolr" version))
+ (sha256
+ (base32 "02gl1sma5cnpd7srpri1g68lpsg3s5n3lr462p5ll8v9s4nllyqj"))))
+ (build-system pyproject-build-system)
(arguments
'(#:tests? #f)) ; Tests require network access.
+ (native-inputs
+ (list python-setuptools
+ python-setuptools-scm
+ python-wheel))
(propagated-inputs
(list python-requests))
- (native-inputs
- (list python-setuptools-scm))
(home-page "https://github.com/django-haystack/pysolr/")
(synopsis "Lightweight python wrapper for Apache Solr")
(description