aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-06 17:43:25 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-19 19:48:49 -0500
commit3dcfec09c3822188fea441c989341d8825aa506f (patch)
treea9783840def7e685df0f43ba4d03f0e3e2755a4c /gnu/packages/perl.scm
parent6f170fe5965bca61ec74ee0df5c59e51db277fa5 (diff)
downloadguix-3dcfec09c3822188fea441c989341d8825aa506f.tar.gz
guix-3dcfec09c3822188fea441c989341d8825aa506f.zip
gnu: Add DateTime-Format-Builder.
* gnu/packages/perl.scm (perl-datetime-format-builder): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 3947757064..e1aabcf5be 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1163,6 +1163,32 @@ combinations. It represents the Gregorian calendar, extended backwards in
time before its creation (in 1582).")
(license artistic2.0)))
+(define-public perl-datetime-format-builder
+ (package
+ (name "perl-datetime-format-builder")
+ (version "0.81")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DR/DROLSKY/"
+ "DateTime-Format-Builder-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vrkzw7kmxnyy403ykxgbg2kvgs99nggi4n9gi09ixivnn68mmbw"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-class-factory-util" ,perl-class-factory-util)
+ ("perl-datetime" ,perl-datetime)
+ ("perl-datetime-format-strptime" ,perl-datetime-format-strptime)
+ ("perl-params-validate" ,perl-params-validate)))
+ (home-page "http://search.cpan.org/dist/DateTime-Format-Builder")
+ (synopsis "Create DateTime parser classes and objects.")
+ (description "DateTime::Format::Builder creates DateTime parsers. Many
+string formats of dates and times are simple and just require a basic regular
+expression to extract the relevant information. Builder provides a simple way
+to do this without writing reams of structural code.")
+ (license artistic2.0)))
+
(define-public perl-datetime-format-strptime
(package
(name "perl-datetime-format-strptime")