aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-06 17:37:23 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-19 19:48:49 -0500
commit6f170fe5965bca61ec74ee0df5c59e51db277fa5 (patch)
tree6a69ba63377e4719265755ae1678c4f775a6c0d0 /gnu/packages/perl.scm
parentbd44b05dcaa678e75f05dc527d82f8ddcaf9d19c (diff)
downloadguix-6f170fe5965bca61ec74ee0df5c59e51db277fa5.tar.gz
guix-6f170fe5965bca61ec74ee0df5c59e51db277fa5.zip
gnu: Add DateTime-Format-Strptime.
* gnu/packages/perl.scm (perl-datetime-format-strptime): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 100fb28ce1..3947757064 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1163,6 +1163,32 @@ combinations. It represents the Gregorian calendar, extended backwards in
time before its creation (in 1582).")
(license artistic2.0)))
+(define-public perl-datetime-format-strptime
+ (package
+ (name "perl-datetime-format-strptime")
+ (version "1.56")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DR/DROLSKY/"
+ "DateTime-Format-Strptime-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0a4bszmff16rw6fz1yr4v9001q9vxrdxnxkj9sqaln83b87rvxig"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-datetime" ,perl-datetime)
+ ("perl-datetime-locale" ,perl-datetime-locale)
+ ("perl-datetime-timezone" ,perl-datetime-timezone)
+ ("perl-params-validate" ,perl-params-validate)))
+ (home-page "http://search.cpan.org/dist/DateTime-Format-Strptime")
+ (synopsis "Parse and format strp and strf time patterns")
+ (description "This module implements most of `strptime(3)`, the POSIX
+function that is the reverse of `strftime(3)`, for `DateTime`. While
+`strftime` takes a `DateTime` and a pattern and returns a string, `strptime`
+takes a string and a pattern and returns the `DateTime` object associated.")
+ (license artistic2.0)))
+
(define-public perl-datetime-locale
(package
(name "perl-datetime-locale")