aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-29 12:52:19 +0200
committerMarius Bakke <marius@gnu.org>2022-08-30 20:43:03 +0200
commitf0cf6b5a3206673e3622e6b8d233a159ea10be96 (patch)
treef807b3dac65b786aa5969a4732e218558a21c7da /gnu/packages/patches
parent0877f66987a6f7d8dc7f3e7381d520a14f4fda5e (diff)
downloadguix-f0cf6b5a3206673e3622e6b8d233a159ea10be96.tar.gz
guix-f0cf6b5a3206673e3622e6b8d233a159ea10be96.zip
gnu: nghttp2: Update to 1.49.0.
* gnu/packages/web.scm (nghttp2): Update to 1.49.0. * gnu/packages/curl.scm (curl)[source](patches): Add compatibility patch. * gnu/packages/patches/curl-nghttp2-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/curl-nghttp2-compat.patch141
1 files changed, 141 insertions, 0 deletions
diff --git a/gnu/packages/patches/curl-nghttp2-compat.patch b/gnu/packages/patches/curl-nghttp2-compat.patch
new file mode 100644
index 0000000000..e3f69c6010
--- /dev/null
+++ b/gnu/packages/patches/curl-nghttp2-compat.patch
@@ -0,0 +1,141 @@
+Use CRLF headers in test responses to cope with newer nghttp2.
+
+Taken from upstream:
+
+ https://github.com/curl/curl/commit/ef121401d6eabed204a716f16b2776ededc75c0e
+
+diff --git a/tests/data/test1700 b/tests/data/test1700
+index 8b1ef4ae336c3..7f78bcf5f92ed 100644
+--- a/tests/data/test1700
++++ b/tests/data/test1700
+@@ -11,26 +11,26 @@ HTTP/2
+ # Server-side
+ <reply>
+ <data nocheck="yes">
+-HTTP/1.1 200 OK
+-Date: Tue, 09 Nov 2010 14:49:00 GMT
+-Server: test-server/fake
+-Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
+-ETag: "21025-dc7-39462498"
+-Accept-Ranges: bytes
+-Content-Length: 6
+-Connection: close
+-Content-Type: text/html
+-Funny-head: yesyes
+-
++HTTP/1.1 200 OK
++Date: Tue, 09 Nov 2010 14:49:00 GMT
++Server: test-server/fake
++Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
++ETag: "21025-dc7-39462498"
++Accept-Ranges: bytes
++Content-Length: 6
++Connection: close
++Content-Type: text/html
++Funny-head: yesyes
++
+ -foo-
+ </data>
+ <data1>
+-HTTP/1.1 200 OK
+-Date: Tue, 09 Nov 2010 14:49:00 GMT
+-Content-Length: 6
+-Connection: close
+-Content-Type: text/html
+-
++HTTP/1.1 200 OK
++Date: Tue, 09 Nov 2010 14:49:00 GMT
++Content-Length: 6
++Connection: close
++Content-Type: text/html
++
+ -maa-
+ </data1>
+ </reply>
+diff --git a/tests/data/test1701 b/tests/data/test1701
+index 3c1a2bd0b8217..22f6147d0503a 100644
+--- a/tests/data/test1701
++++ b/tests/data/test1701
+@@ -11,17 +11,17 @@ HTTP/2
+ # Server-side
+ <reply>
+ <data nocheck="yes">
+-HTTP/1.1 200 OK
+-Date: Tue, 09 Nov 2010 14:49:00 GMT
+-Server: test-server/fake
+-Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
+-ETag: "21025-dc7-39462498"
+-Accept-Ranges: bytes
+-Content-Length: 6
+-Connection: close
+-Content-Type: text/html
+-Funny-head: yesyes
+-
++HTTP/1.1 200 OK
++Date: Tue, 09 Nov 2010 14:49:00 GMT
++Server: test-server/fake
++Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
++ETag: "21025-dc7-39462498"
++Accept-Ranges: bytes
++Content-Length: 6
++Connection: close
++Content-Type: text/html
++Funny-head: yesyes
++
+ -foo-
+ </data>
+ </reply>
+diff --git a/tests/data/test358 b/tests/data/test358
+index 8b4f6606247a0..0f8a9801bbcb5 100644
+--- a/tests/data/test358
++++ b/tests/data/test358
+@@ -12,14 +12,14 @@ HTTP/2
+ # Server-side
+ <reply>
+ <data nocheck="yes">
+-HTTP/1.1 200 OK
+-Date: Tue, 09 Nov 2010 14:49:00 GMT
+-Content-Length: 6
+-Connection: close
+-Content-Type: text/html
+-Funny-head: yesyes
+-Alt-Svc: h2=":%HTTP2PORT", ma=315360000; persist=0
+-
++HTTP/1.1 200 OK
++Date: Tue, 09 Nov 2010 14:49:00 GMT
++Content-Length: 6
++Connection: close
++Content-Type: text/html
++Funny-head: yesyes
++Alt-Svc: h2=":%HTTP2PORT", ma=315360000; persist=0
++
+ -foo-
+ </data>
+ </reply>
+diff --git a/tests/data/test359 b/tests/data/test359
+index a5ba4e3ae0971..0e684e39e5aa5 100644
+--- a/tests/data/test359
++++ b/tests/data/test359
+@@ -12,14 +12,14 @@ HTTP/2
+ # Server-side
+ <reply>
+ <data nocheck="yes">
+-HTTP/1.1 200 OK
+-Date: Tue, 09 Nov 2010 14:49:00 GMT
+-Content-Length: 6
+-Connection: close
+-Content-Type: text/html
+-Funny-head: yesyes
+-Alt-Svc: h2=":%HTTP2PORT", ma=315360000; persist=0
+-
++HTTP/1.1 200 OK
++Date: Tue, 09 Nov 2010 14:49:00 GMT
++Content-Length: 6
++Connection: close
++Content-Type: text/html
++Funny-head: yesyes
++Alt-Svc: h2=":%HTTP2PORT", ma=315360000; persist=0
++
+ -foo-
+ </data>
+ </reply>