aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-29 12:52:19 +0200
committerMarius Bakke <marius@gnu.org>2022-08-30 20:43:03 +0200
commitf0cf6b5a3206673e3622e6b8d233a159ea10be96 (patch)
treef807b3dac65b786aa5969a4732e218558a21c7da /gnu
parent0877f66987a6f7d8dc7f3e7381d520a14f4fda5e (diff)
downloadguix-f0cf6b5a3206673e3622e6b8d233a159ea10be96.tar.gz
guix-f0cf6b5a3206673e3622e6b8d233a159ea10be96.zip
gnu: nghttp2: Update to 1.49.0.
* gnu/packages/web.scm (nghttp2): Update to 1.49.0. * gnu/packages/curl.scm (curl)[source](patches): Add compatibility patch. * gnu/packages/patches/curl-nghttp2-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/curl.scm1
-rw-r--r--gnu/packages/patches/curl-nghttp2-compat.patch141
-rw-r--r--gnu/packages/web.scm4
4 files changed, 145 insertions, 2 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index de6a65b0f5..d16cf9f3f7 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -988,6 +988,7 @@ dist_patch_DATA = \
%D%/packages/patches/clucene-contribs-lib.patch \
%D%/packages/patches/cube-nocheck.patch \
%D%/packages/patches/curl-easy-lock.patch \
+ %D%/packages/patches/curl-nghttp2-compat.patch \
%D%/packages/patches/curl-use-ssl-cert-env.patch \
%D%/packages/patches/cursynth-wave-rand.patch \
%D%/packages/patches/cvs-CVE-2017-12836.patch \
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 3b4e4233f1..600163bf72 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -72,6 +72,7 @@
(base32
"1f2xgj0wvys9xw50h7vcbaraavjr9rxx9n06x2xfbgs7ym1qn49d"))
(patches (search-patches "curl-use-ssl-cert-env.patch"
+ "curl-nghttp2-compat.patch"
"curl-easy-lock.patch"))))
(build-system gnu-build-system)
(outputs '("out"
diff --git a/gnu/packages/patches/curl-nghttp2-compat.patch b/gnu/packages/patches/curl-nghttp2-compat.patch
new file mode 100644
index 0000000000..e3f69c6010
--- /dev/null
+++ b/gnu/packages/patches/curl-nghttp2-compat.patch
@@ -0,0 +1,141 @@
+Use CRLF headers in test responses to cope with newer nghttp2.
+
+Taken from upstream:
+
+ https://github.com/curl/curl/commit/ef121401d6eabed204a716f16b2776ededc75c0e
+
+diff --git a/tests/data/test1700 b/tests/data/test1700
+index 8b1ef4ae336c3..7f78bcf5f92ed 100644
+--- a/tests/data/test1700
++++ b/tests/data/test1700
+@@ -11,26 +11,26 @@ HTTP/2
+ # Server-side
+ <reply>
+ <data nocheck="yes">
+-HTTP/1.1 200 OK
+-Date: Tue, 09 Nov 2010 14:49:00 GMT
+-Server: test-server/fake
+-Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
+-ETag: "21025-dc7-39462498"
+-Accept-Ranges: bytes
+-Content-Length: 6
+-Connection: close
+-Content-Type: text/html
+-Funny-head: yesyes
+-
++HTTP/1.1 200 OK
++Date: Tue, 09 Nov 2010 14:49:00 GMT
++Server: test-server/fake
++Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
++ETag: "21025-dc7-39462498"
++Accept-Ranges: bytes
++Content-Length: 6
++Connection: close
++Content-Type: text/html
++Funny-head: yesyes
++
+ -foo-
+ </data>
+ <data1>
+-HTTP/1.1 200 OK
+-Date: Tue, 09 Nov 2010 14:49:00 GMT
+-Content-Length: 6
+-Connection: close
+-Content-Type: text/html
+-
++HTTP/1.1 200 OK
++Date: Tue, 09 Nov 2010 14:49:00 GMT
++Content-Length: 6
++Connection: close
++Content-Type: text/html
++
+ -maa-
+ </data1>
+ </reply>
+diff --git a/tests/data/test1701 b/tests/data/test1701
+index 3c1a2bd0b8217..22f6147d0503a 100644
+--- a/tests/data/test1701
++++ b/tests/data/test1701
+@@ -11,17 +11,17 @@ HTTP/2
+ # Server-side
+ <reply>
+ <data nocheck="yes">
+-HTTP/1.1 200 OK
+-Date: Tue, 09 Nov 2010 14:49:00 GMT
+-Server: test-server/fake
+-Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
+-ETag: "21025-dc7-39462498"
+-Accept-Ranges: bytes
+-Content-Length: 6
+-Connection: close
+-Content-Type: text/html
+-Funny-head: yesyes
+-
++HTTP/1.1 200 OK
++Date: Tue, 09 Nov 2010 14:49:00 GMT
++Server: test-server/fake
++Last-Modified: Tue, 13 Jun 2000 12:10:00 GMT
++ETag: "21025-dc7-39462498"
++Accept-Ranges: bytes
++Content-Length: 6
++Connection: close
++Content-Type: text/html
++Funny-head: yesyes
++
+ -foo-
+ </data>
+ </reply>
+diff --git a/tests/data/test358 b/tests/data/test358
+index 8b4f6606247a0..0f8a9801bbcb5 100644
+--- a/tests/data/test358
++++ b/tests/data/test358
+@@ -12,14 +12,14 @@ HTTP/2
+ # Server-side
+ <reply>
+ <data nocheck="yes">
+-HTTP/1.1 200 OK
+-Date: Tue, 09 Nov 2010 14:49:00 GMT
+-Content-Length: 6
+-Connection: close
+-Content-Type: text/html
+-Funny-head: yesyes
+-Alt-Svc: h2=":%HTTP2PORT", ma=315360000; persist=0
+-
++HTTP/1.1 200 OK
++Date: Tue, 09 Nov 2010 14:49:00 GMT
++Content-Length: 6
++Connection: close
++Content-Type: text/html
++Funny-head: yesyes
++Alt-Svc: h2=":%HTTP2PORT", ma=315360000; persist=0
++
+ -foo-
+ </data>
+ </reply>
+diff --git a/tests/data/test359 b/tests/data/test359
+index a5ba4e3ae0971..0e684e39e5aa5 100644
+--- a/tests/data/test359
++++ b/tests/data/test359
+@@ -12,14 +12,14 @@ HTTP/2
+ # Server-side
+ <reply>
+ <data nocheck="yes">
+-HTTP/1.1 200 OK
+-Date: Tue, 09 Nov 2010 14:49:00 GMT
+-Content-Length: 6
+-Connection: close
+-Content-Type: text/html
+-Funny-head: yesyes
+-Alt-Svc: h2=":%HTTP2PORT", ma=315360000; persist=0
+-
++HTTP/1.1 200 OK
++Date: Tue, 09 Nov 2010 14:49:00 GMT
++Content-Length: 6
++Connection: close
++Content-Type: text/html
++Funny-head: yesyes
++Alt-Svc: h2=":%HTTP2PORT", ma=315360000; persist=0
++
+ -foo-
+ </data>
+ </reply>
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7f0f265217..2004182c17 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7493,7 +7493,7 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
(define-public nghttp2
(package
(name "nghttp2")
- (version "1.48.0")
+ (version "1.49.0")
(source
(origin
(method url-fetch)
@@ -7502,7 +7502,7 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
"nghttp2-" version ".tar.xz"))
(sha256
(base32
- "1r0ns1r6g03wji273nk3bhrkmj1s3g5640yicqan5g7iwh7g7n27"))))
+ "0vm692c7q2wc4xxz8c41nr8jps2fkwf51xp8fb233cghpf9d9kxh"))))
(build-system gnu-build-system)
(outputs (list "out"
"lib")) ; only libnghttp2