aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-08-14 15:50:38 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:45 +0200
commitcfd67d36b53f920a43efe3716a1d670127310a27 (patch)
tree847bee4fdd23d333e3131d84b4a636fc8c6f520c /gnu/packages/make-bootstrap.scm
parent9fe0e5b35307e4392d0297095116933a435b2c48 (diff)
downloadguix-cfd67d36b53f920a43efe3716a1d670127310a27.tar.gz
guix-cfd67d36b53f920a43efe3716a1d670127310a27.zip
gnu: make-bootstrap: Fix statically-linked ‘grep’ compilation.
The ‘%static-inputs’ list is used by ‘bootstrap-tarballs’ for systems other than x86_64-linux and i686-linux. * gnu/packages/make-bootstrap.scm (%static-inputs): Pass ‘--disable-perl-regexp’ and remove ‘--enable-perl-regexp’ for grep. Change-Id: Id9cc8c026eee5031b00c1824624fe6da205d55eb
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 13cf40d37b..d5b6b818b3 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -267,9 +267,12 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(inputs '()) ;remove PCRE, which is optional
(arguments
(substitute-keyword-arguments (package-arguments grep)
+ ((#:configure-flags flags #~'())
+ #~(cons "--disable-perl-regexp"
+ (delete "--enable-perl-regexp" #$flags)))
((#:phases phases)
- `(modify-phases ,phases
- (delete 'fix-egrep-and-fgrep)))))))
+ #~(modify-phases #$phases
+ (delete 'fix-egrep-and-fgrep)))))))
(finalize (compose static-package
package-with-relocatable-glibc)))
(append (map finalize