aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/make-bootstrap.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 13cf40d37b..d5b6b818b3 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -267,9 +267,12 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(inputs '()) ;remove PCRE, which is optional
(arguments
(substitute-keyword-arguments (package-arguments grep)
+ ((#:configure-flags flags #~'())
+ #~(cons "--disable-perl-regexp"
+ (delete "--enable-perl-regexp" #$flags)))
((#:phases phases)
- `(modify-phases ,phases
- (delete 'fix-egrep-and-fgrep)))))))
+ #~(modify-phases #$phases
+ (delete 'fix-egrep-and-fgrep)))))))
(finalize (compose static-package
package-with-relocatable-glibc)))
(append (map finalize