aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:10 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:19 +0200
commit946b0274cc4bf23d8e57ad85812add03409d4fd3 (patch)
tree13cd5140cb16934b46967d0c617091dcaa3763b0 /gnu/packages/haskell-xyz.scm
parent766bd586dcad93311819a610360784917575efdf (diff)
downloadguix-946b0274cc4bf23d8e57ad85812add03409d4fd3.tar.gz
guix-946b0274cc4bf23d8e57ad85812add03409d4fd3.zip
gnu: Add ghc-checkers.
* gnu/packages/haskell-xyz.scm (ghc-checkers): New variable. Change-Id: I4228398238a169e49e68ead60cbe69ef0437e3e9
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index bc962c82ac..cf188fe896 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -1830,6 +1830,31 @@ linear performance. Output is sanitized by default for protection against
cross-site scripting (@dfn{XSS}) attacks.")
(license license:bsd-3)))
+(define-public ghc-checkers
+ (package
+ (name "ghc-checkers")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "checkers" version))
+ (sha256
+ (base32 "1r4rsa4k0fy8xig3m530ryflry9viv9v47g4gh7h0ld27rbd6z60"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "checkers")))
+ (inputs (list ghc-random ghc-quickcheck ghc-semigroupoids))
+ (arguments
+ `(#:cabal-revision ("1"
+ "0wkvf57zd7i87z18vj285whjpcl9pscpwxz2cp7v7w6kk0769p0i")))
+ (home-page "https://github.com/haskell-checkers/checkers")
+ (synopsis "Check properties on standard classes and data structures")
+ (description
+ "Checkers wraps up the expected properties associated with various
+standard type classes as @code{QuickCheck} properties. It also provides some
+morphism properties, arbitrary instances, and generator combinators for common
+data types.")
+ (license license:bsd-3)))
+
(define-public ghc-chell
(package
(name "ghc-chell")