aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:09 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:19 +0200
commit766bd586dcad93311819a610360784917575efdf (patch)
tree333ad41fdec20bd5c7570d6a241ecffc154038c6 /gnu/packages/haskell-xyz.scm
parent848666c9918f2f41d3a1e6d4b53d9e272bbfd20d (diff)
downloadguix-766bd586dcad93311819a610360784917575efdf.tar.gz
guix-766bd586dcad93311819a610360784917575efdf.zip
gnu: Add ghc-bimap.
* gnu/packages/haskell-xyz.scm (ghc-bimap): New variable. Change-Id: Ib6ffebff5417273afaa3a08005aae3445606d6d2
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 6912e78cbc..bc962c82ac 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -972,6 +972,27 @@ storing and transmitting loosely structured data.")
(description "This package provides bifunctors for Haskell.")
(license license:bsd-3)))
+(define-public ghc-bimap
+ (package
+ (name "ghc-bimap")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "bimap" version))
+ (sha256
+ (base32 "158cdwk9jwklcfgbn62dqq255i40w13ifggsdps87sxc5q7lpd5h"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "bimap")))
+ (native-inputs (list ghc-quickcheck))
+ (home-page "https://github.com/joelwilliamson/bimap")
+ (synopsis "Bidirectional mapping between two key types")
+ (description
+ "This package provides a data structure representing a bidirectional
+mapping between two key types. Each value in the bimap is associated with
+exactly one value of the opposite type.")
+ (license license:bsd-3)))
+
(define-public ghc-bindings-dsl
(package
(name "ghc-bindings-dsl")