aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:08 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:19 +0200
commit848666c9918f2f41d3a1e6d4b53d9e272bbfd20d (patch)
tree3b1daf7f37c26f6fb86c3332be936c44fa088414 /gnu/packages/haskell-xyz.scm
parent35bc1a5991c0ed405b581f35377f98a7befb4f1e (diff)
downloadguix-848666c9918f2f41d3a1e6d4b53d9e272bbfd20d.tar.gz
guix-848666c9918f2f41d3a1e6d4b53d9e272bbfd20d.zip
gnu: Add ghc-aspell-pipe.
* gnu/packages/haskell-xyz.scm (ghc-aspell-pipe): New variable. Change-Id: I0d31c9c457ce33b45c0fb6589413208796843920
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index fa423ae2ca..6912e78cbc 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -450,6 +450,26 @@ colored output using the ansi-terminal package.")
style.")
(license license:bsd-3)))
+(define-public ghc-aspell-pipe
+ (package
+ (name "ghc-aspell-pipe")
+ (version "0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "aspell-pipe" version))
+ (sha256
+ (base32 "09dw4v4j5pmqi8pdh3p7kk7f8pph5w33s7vd21fgvhv3arnrj6p8"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "aspell-pipe")))
+ (inputs (list ghc-async))
+ (home-page "https://hackage.haskell.org/package/aspell-pipe")
+ (synopsis "Pipe-based interface to the Aspell program")
+ (description
+ "This package provides a pipe-based interface to the Aspell program (no
+dynamic linking required).")
+ (license license:bsd-3)))
+
(define-public ghc-assoc
(package
(name "ghc-assoc")