aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:15 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:20 +0200
commit26746cd7b49f1276f59db3a11356867ba08ab192 (patch)
treeecf0352f6eb4648954d0ecb49ca56381cfae1ae4 /gnu/packages/haskell-xyz.scm
parentc290c44c51ef385613fd835afc2ae7f1affc128e (diff)
downloadguix-26746cd7b49f1276f59db3a11356867ba08ab192.tar.gz
guix-26746cd7b49f1276f59db3a11356867ba08ab192.zip
gnu: Add ghc-unix-compat-7.
* gnu/packages/haskell-xyz.scm (ghc-unix-compat-7): New variable. Change-Id: I28e8e4924d4f829dd07059aa205d894803409320
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm28
1 files changed, 25 insertions, 3 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 006042fd14..6115bb1538 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13430,9 +13430,31 @@ elements in a list.")
(home-page "https://github.com/jacobstanley/unix-compat")
(synopsis "Portable POSIX-compatibility layer")
(description
- "This package provides portable implementations of parts of the unix
-package. This package re-exports the unix package when available. When it
-isn't available, portable implementations are used.")
+ "This package provides portable implementations of parts of the
+@code{unix} package. This package re-exports the @code{unix} package when
+available. When it isn't available, portable implementations are used.")
+ (license license:bsd-3)))
+
+(define-public ghc-unix-compat-7
+ (package
+ (name "ghc-unix-compat")
+ (version "0.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "unix-compat" version))
+ (sha256
+ (base32 "0gz30f4g3gyjz60jbcg072ms67pwdn4by6wvdkg63hjshgl0cj60"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "unix-compat")))
+ (native-inputs (list ghc-monad-parallel ghc-hspec ghc-hunit ghc-extra
+ ghc-temporary))
+ (home-page "https://github.com/haskell-pkg-janitors/unix-compat")
+ (synopsis "Portable POSIX-compatibility layer")
+ (description
+ "This package provides portable implementations of parts of the unix package.
+This package re-exports the unix package when available. When it isn't
+available, portable implementations are used.")
(license license:bsd-3)))
(define-public ghc-unix-time