aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:14 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:20 +0200
commitc290c44c51ef385613fd835afc2ae7f1affc128e (patch)
tree8a44df79b85fad1586c7a55718c551d32825afab /gnu/packages/haskell-xyz.scm
parentc617cbb0fb968cbe66ab4f7a003bc2ee6dc85868 (diff)
downloadguix-c290c44c51ef385613fd835afc2ae7f1affc128e.tar.gz
guix-c290c44c51ef385613fd835afc2ae7f1affc128e.zip
gnu: Add ghc-unique.
* gnu/packages/haskell-xyz.scm (ghc-unique): New variable. * gnu/packages/patches/ghc-unique-support-newer-hashable.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Change-Id: Id9876b8018f5f8b3bcb82ab0bb13616ed298c31b
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index b3e7a45602..006042fd14 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13387,6 +13387,31 @@ operations. Uniplate has similar goals to the original Scrap Your Boilerplate
work, but is substantially simpler and faster.")
(license license:bsd-3)))
+(define-public ghc-unique
+ (package
+ (name "ghc-unique")
+ (version "0.4.7.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "Unique" version))
+ (sha256
+ (base32 "14f1qnmhdmbam8qis725dhwq1mk9h86fsnzhkwhsx73ny9z29s1l"))
+ (patches (search-patches "ghc-unique-support-newer-hashable.patch"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "Unique")))
+ (inputs (list ghc-extra ghc-hashable ghc-unordered-containers))
+ (native-inputs (list ghc-hspec ghc-quickcheck))
+ (arguments
+ `(#:cabal-revision ("1"
+ "10s0npnfkh7naj49afmyrvnilikp6426fbhi49f97pxrgcmy4dvw")))
+ (home-page "https://hackage.haskell.org/package/Unique")
+ (synopsis "Haskell functionality like \"uniq\" tool")
+ (description
+ "This library provides the functions to find unique and duplicate
+elements in a list.")
+ (license license:bsd-3)))
+
(define-public ghc-unix-compat
(package
(name "ghc-unix-compat")