aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-13 12:00:39 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:45 +0000
commitd265bffc4f41f6d3f37fa1afb040b63a47bc1289 (patch)
treeb1962ef84586127ebb15e59dd440a81361040f80 /gnu/packages/golang.scm
parent66c2875952b70709f99580f2a3c4db56c8997c28 (diff)
downloadguix-d265bffc4f41f6d3f37fa1afb040b63a47bc1289.tar.gz
guix-d265bffc4f41f6d3f37fa1afb040b63a47bc1289.zip
gnu: go-github-com-google-btree: Move to golang-build.
* gnu/packages/golang.scm (go-github-com-google-btree): Move from here ... * gnu/packages/golang-build.scm: ... to here. Change-Id: I91c659b9031291a4e6c43b024dedaa1bfcb7cea3
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 0 insertions, 23 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9ff46d23bb..2cf7773c3b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7679,29 +7679,6 @@ implementation.")
using shell-style rules for quoting and commenting.")
(license license:asl2.0)))
-(define-public go-github-com-google-btree
- (package
- (name "go-github-com-google-btree")
- (version "1.1.3")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/btree")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1k3jfj24sp4qk494wxj055vf5fjwskiydscy4a42s5jiwgcjr9gz"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/google/btree"))
- (home-page "https://github.com/google/btree")
- (synopsis "Simple, ordered, in-memory data structure for Go programs")
- (description
- "This package provides an in-memory B-Tree implementation for Go, useful as an
-ordered, mutable data structure.")
- (license license:asl2.0)))
-
(define-public go-github-com-peterbourgon-diskv
(package
(name "go-github-com-peterbourgon-diskv")