aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-build.scm24
-rw-r--r--gnu/packages/golang.scm23
2 files changed, 24 insertions, 23 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index c7bed8133f..8fdd652b63 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -140,6 +140,30 @@ functions that have a name matched by regex:.")
serialization format.")
(license license:bsd-3)))
+(define-public go-github-com-google-btree
+ (package
+ (name "go-github-com-google-btree")
+ (version "1.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/btree")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1k3jfj24sp4qk494wxj055vf5fjwskiydscy4a42s5jiwgcjr9gz"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/google/btree"))
+ (home-page "https://github.com/google/btree")
+ (synopsis "Simple, ordered, in-memory data structure for Go programs")
+ (description
+ "This package provides an in-memory B-Tree implementation for Go, useful
+as an ordered, mutable data structure.")
+ (license license:asl2.0)))
+
(define-public go-github-com-google-go-cmdtest
(package
(name "go-github-com-google-go-cmdtest")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9ff46d23bb..2cf7773c3b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7679,29 +7679,6 @@ implementation.")
using shell-style rules for quoting and commenting.")
(license license:asl2.0)))
-(define-public go-github-com-google-btree
- (package
- (name "go-github-com-google-btree")
- (version "1.1.3")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/btree")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1k3jfj24sp4qk494wxj055vf5fjwskiydscy4a42s5jiwgcjr9gz"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/google/btree"))
- (home-page "https://github.com/google/btree")
- (synopsis "Simple, ordered, in-memory data structure for Go programs")
- (description
- "This package provides an in-memory B-Tree implementation for Go, useful as an
-ordered, mutable data structure.")
- (license license:asl2.0)))
-
(define-public go-github-com-peterbourgon-diskv
(package
(name "go-github-com-peterbourgon-diskv")