aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-13 10:35:18 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:44 +0000
commit4b7a0b83c1e071dc870cfc0976adc843e83ec01f (patch)
tree967a4f3addcc42ebbbef013a40d0728d7c69bbc6 /gnu/packages/golang.scm
parenta59917ea8fd86b35f3ccd6179a0f67be5767712a (diff)
downloadguix-4b7a0b83c1e071dc870cfc0976adc843e83ec01f.tar.gz
guix-4b7a0b83c1e071dc870cfc0976adc843e83ec01f.zip
gnu: Remove go-github-com-jba-printsrc.
It's not in use by any packages in Guix, no updates for 3y. * gnu/packages/golang.scm (go-github-com-jba-printsrc): Delete variable. Change-Id: I6bfa658be1cf2846fa94d408da3baf11da01d779
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 0 insertions, 25 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8257f571b4..6ded98045f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6214,31 +6214,6 @@ This makes it virtually free to implement mocks and testing over
file system operations.")
(license license:asl2.0)))
-(define-public go-github-com-jba-printsrc
- (package
- (name "go-github-com-jba-printsrc")
- (version "0.2.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jba/printsrc")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1gyy3kmb5a5i710wkv3b7ah7i7sz5sdc7v3sab5m4rxch1sd2fpj"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/jba/printsrc"
- ;; TODO: Open bug; expecting time.Local, but when local=UTC, we get time.UTC
- #:tests? #f))
- (home-page "https://github.com/jba/printsrc")
- (synopsis "Prints Go values as sourcecode")
- (description
- "Package printsrc prints Go values as Go source. It strives to render
-legal Go source code, and returns an error when detects that it cannot.")
- (license license:expat)))
-
(define-public go-github-com-jba-templatecheck
(package
(name "go-github-com-jba-templatecheck")